Dynamic macro stop working with new editor

I’m author of one of the macros from Atlassian marketplace. It worked fine for many instances but recently with the introduction of new editor it stopped working there.

The macro can be inserted to the body while editing page.
Then when page is published it only shows text ‘extension’. no requests to macro’s server sent by page.
When opening page in editor the following error is displayed instead of macro box “confluenceADFMigrationUnsupportedContentInternalExtension”.

I don’t see any macro specific error in browser’s console.

What does it mean? Where can I read what has changed with new editor so that I can adapt my macro to it.

PS: I’ve tried other macros’ and the result is the same. It looks like it’s not only mine issue.

Hi @stepashka,
There’s been a number of different issues reported against the new editor experience and macros. Please see the following issues for more information and there may be others reported I’m not aware of.

https://jira.atlassian.com/browse/CONFCLOUD-64923#
https://jira.atlassian.com/browse/CONFCLOUD-65717

Hopefully, you’ll find something in there for you.

Thanks for the reference. It was indeed this one https://jira.atlassian.com/browse/CONFCLOUD-65717 .

Our addons are also facing this issue. Can anyone share how this is resolved if at all?

Unfortunately there is no way to make it work so far. you can see Atlassian’s promise here https://community.atlassian.com/t5/Confluence-discussions/3rd-party-apps-with-plain-text-macros-will-now-be-compatible/m-p/1092497 but according to the comments it is not fixed yet.

This is the ticket https://jira.atlassian.com/browse/CONFCLOUD-65717 closed but not fixed.