Dynamic webhooks created via v3 REST API dont fire

We are trying to create dynamic webhooks via the V3 REST API from an OAuth2 app. The webhooks are created successfully, but never fire. We seem to have exhausted all possible solutions to get webhooks to fire.

A simple demo can be seen here https://github.com/tlou006/test-jira-webhook/blob/main/src/App.js
(A simple create-react-app, with buttons to initiate OAuth and create/delete webhooks)

A full overview of our setup

  • A published Jira App
    • Scopes: read/write:jira-work, manage:jira-webhooks, offline_access (only for the OAuth url)
  • An internet accessible proxy for testing webhooks
    • We have tried both Ngrok and requestbin endpoints
  • A test Jira project with various dummy issues that are closed/created/updated/deleted

Here are the solutions that have not worked for us.

  • Matching the Jira App redirect url with the webhook url
  • Creating multiple webhooks for a single event vs creating a single webhook for multiple events (issueUpdated/issueCreated/issueDeleted etc.)
  • Confirmed that dynamic webhooks are created and visible via the REST API (GET /webhook)
  • Confirmed that there were no failed webhooks (via GET /webhook/failed)
  • Confirmed our proxies are working and catching webhook requests from other services/products
  • Tried different jql combinations
    • project specific (i.e. project = 10000, or project = KAN)
    • broad queries (i.e. status = Done or status != Done)
  • Tried various combinations of Jira App scopes, including granular webhook scopes
  • Tried giving the OAuth user either limited or maximal permissions on the Jira account
  • Paying for a Standard subscription on the Jira account

We would love to get some insight into this.

Would you mind to share with me the sitename or cloudId (here or via email - bszturemska@atlassian.com)?

Thanks for following up! I have emailed you with the details.

I’d like to let you know that thanks to data provided by @TomyLou we were able to identify an issue specific to a single region causing that we are not delivering webhooks to Outh2 apps.
The issue is now resolved.

Thank you Tom for your report.


Hi @BeataSzturemska

It looks like I have the exact same issue. Would you be able to take a look at my case too please? I will email you my cloudId