Error : A permission sync is already running on the tenant

I have this Error: Error sending connect plugin lifecycle event callback: A permission sync is already running on the tenant

this is blocking me, I tried uninstalling the app from Confluence and reinstalling it, still get the same error. The same app works fine on Jira and confluence production.

Is there a way to force stop the permission sync on tenant ?

urgent help required please …

1 Like

I countered the same problem. Have you found a solution?
Thanks in advance

Here is what helped me: create a new empty app on Forge, copy app id from new to old one, deploy and install.

@AbhishekBiswas Did the issue resolve itself since yesterday?

@veloti Thanks for posting the workaround the worked for you (may not be a viable option for folks with published apps and many installs in production).

This issue has come up in some internal discussions in the past; however, I don’t currently see any workarounds/fixes other than waiting for the background task to complete. I’ll see what else I can find out and share.


I didn’t manage to fix it, I just gave up as I was running for a deadline, so created a new app and didn’t encountered the same problem fortunately.

Nevermind, thanks for the workarounds, I am developing a development app for now, so a lot of freedom in these cases :slight_smile: