Error loading the extension! when adding read:jira-work scope


I’m currently working on a forge confluence macro app. I have got to the point where I need to call one of the REST apis like so:

await api.asUser().requestJira(route/rest/api/3/filter/search);

When doing a forge deloy I was asked to add the scope, so did. Then reran forge deloy and forge install --upgrade

Now am presented with this error when viewing the macro.

I have no idea whats needed to solve this. I have tried removing the scope and redeploying and my app works again.


Hi @Stoff81

Try deleting the macro from the page and adding it again. Also, try clearing your browser cache.


Thanks for suggestion, I have tried in an incognito session and still the same problem exists. I have now noticed that when the permissions are enabled the macro isn’t even present at all. Its not in the list of macros to create. Interestingly, when the permissions are enabled it has also removed my other macros from the confluence instance.

Removing the permissions again makes existing macros work and add them back to the list of available macros. So it seems like setting the permissions is preventing the macro to even be accepted by the confluence instant. Is there some settings that need to change in the confluence instance?



I don’t know of any settings to change to make it work. My confluence macro normally work after deploy and install/upgrade.

May be you can try a new instance or try some working forge examples on the current instance. To determine if there is a problem with your account


I just tried the forge-feedback-collector which has the same permissions in the manifest. It causes the same issues. I am out of ideas?


I had to deploy the app to Jira AS WELL AS confluence. That wasn’t made clear in any docs I read but noticed that in some examples of the forge install there was jira instances as well as confluence ones.