Error when installing self-developed Add-on

Dear all,

we are facing an issue where it is not possible to install an add-on (called title add-on) which we had installed before.

It was installed and working but we were facing an issue with the SSL certificates. Over the course of solving the SSL issue we deinstalled the title add-on. After the SSL certificate issue had been solved we tried reinstalling the title add-on. Since then we keep getting the error shown above. We did not change the source code of the title add-on.

We have similar add-ons which we did not deinstall while solving the SSL certificate issue. All of these other add-ons work fine and are having no troubles to be installed.

Technical data:

  • The plugins are running on a nginx webserver with a pm2 process manager
  • nginx.conf: all add-ons have the same config (only the ports are different)

Did anyone ever had a similar issue or has an idea how to solve this kind of an issue?

Best regards,

We have resolved the issue:
The reason that your descriptor cannot be fetched is because we were serving it from a non-standard http port number (8050). It must be served using port 443.

This was changed recently.