Error when setting distribution to sharing in developer console

I am currently experiencing an error when trying to set the distribution status of my app to sharing. I receive a message stating “Error - Something went wrong.”

I looked in the network response and it states Server Error:

JSON
errors: [{...}]
    0: Object {message: "Server error"}
        message: "Server error"

Not sure what direction to pursue to remedy this. I also noticed when trying to save the description or logo for the app nothing is saved.

1 Like

Hey, @MichaelRaphael1 this probably fits better into a support ticket :slight_smile: However, let’s try to solve your case here. Quite often the problem is a privacy policy URL. Our checks expect a request to this URL to return a 200 OK status code. Often developers forget a trailing slash or instead, add it and the server returns a 301 to a page with/without a slash. Could you please check that your privacy policy URL returns a 200 OK?

1 Like

Sorry about that will follow that route next time :see_no_evil: . I am receiving a 200 response when I load the page and when I use curl in the terminal. I do have the trailing slash. Without the trailing slash I receive a 301 code. When filling in the distribution controls my privacy policy URL did contain the trailing slash. This is our privacy policy (notice)

@MichaelRaphael1 all good. I was able to reproduce the issue with your URL. We will investigate what’s wrong with it (our logs show that it’s 301. However, I get back 200 OK with curl). In the meantime, you can specify any 200 OK URL (https://www.google.com as an example) as a privacy policy URL to unblock yourself. Either I or my colleagues will post in this thread when we find the root cause of the issue.

Hi @MichaelRaphael1, This issue got passed over to the team I’m with, and we found that it seems to fail because of the page redirecting to itself. It looks as though the 301 comes from this. In testing, following the redirects give us a 414 error for the URL being too long after the page tried to redirect to itself infinitely.

This seems from our end like invalid behaviour for the page. We think that this is the root cause of the issue.

A similar issue happened to me today. A more verbose error message would be appreciated, even an “Invalid URL” hint. Anyways, thanks for the workarounds!