Failed connect to api.trello.com:443 - Connection refused

Hello everyone!

I integrated my web application with Trello’s REST API.
I used the following method: ‘https://api.trello.com/1/members/me/boards?key={yourKey}&token={yourToken}’, that I putted my key and token.

In sometime, it works, after three ou four requests, the Trello’s REST API starts to return to my application ‘Connection refused’ like this: Failed connect to api.trello.com:443"; Connection refused.

I tried telnet command from my server e received the following message:
“telnet 23.36.86.242 443
Trying 23.36.86.242…
telnet: connect to address 23.36.86.242: Connection refused”

I appreciate anything that can help me in that problem.

Thank you in advance!

What is the API key you are using?

Also, what is the IP address you are sending these requests from?

I am using the API Key: 302ec0794261f920a0bf8e8de4567454

And I am sending these requests from IP: 192.175.112.170

Thank you!

@bcook, could you check anything to help me?

Thank you!

It sounds like your outbound server may be occasionally losing network access? We don’t have any restrictions on the IP you listed, and even if we did, you’d get back an http response.

No, we already checked the outbound server and is not blocked.

We can’t get back http response because the request is denied by Trello server.

We did a test in Jira API (18.234.32.192) and everything works.

The problem is that the Trello Server is denning our IP.

Can you check again?

Thank you in advance!

@bcook can you still help me with anything?

@bcook can you still help us?

Nothing apparent on our side would cause this.

Looking at other issues indicates that the request is never making it out of your network: https://github.com/stevenmaguire/trello-php/issues/14.

Thank you @bcook by your help!

After sometimes denny, my hosting unblocked the IP in firewall.

The problem is solved. I’ll mark as completed the thread.