Failed to read artifact descriptor for com.elements-apps.elements-connect.api:elements-connect-api:jar:0.3.0

Why am I getting this error?

[[ERROR] Failed to execute goal on project technology-solutions-plugin-jira: Could not resolve dependencies for project ca.fcc.jiraplugin:technology-solutions-plugin-jira:atlassian-plugin:1.11: Failed to collect dependencies at com.elements-apps.elements-connect.api:elements-connect-api:jar:0.3.0: Failed to read artifact descriptor for com.elements-apps.elements-connect.api:elements-connect-api:jar:0.3.0: Could not transfer artifact com.elements-apps.elements-connect.api:elements-connect-api:pom:0.3.0 from/to atlassian-public (https://maven.atlassian.com/repository/public): PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 1]

My pom.xml is configured according to this:

https://doc.elements-apps.com/elements-connect/latest/api-guide/java-api#id-.JavaAPIv6.13-Maven

and nothing was changed there but can’t compile it (was working last week)


 <dependencies>
        <dependency>
            <groupId>com.elements-apps.elements-connect.api</groupId>
            <artifactId>elements-connect-api</artifactId>
            <version>0.3.0</version>
            <scope>provided</scope>
        </dependency>
        <dependency>
            <groupId>org.codehaus.groovy.modules.http-builder</groupId>
            <artifactId>http-builder</artifactId>
            <version>0.7.1</version>
            <scope>provided</scope>
        </dependency>
        <!-- Thanks for using https://jar-download.com -->
        <!-- Jira Cloud dependencies -->
        <dependency>
            <groupId>com.mashape.unirest</groupId>
            <artifactId>unirest-java</artifactId>
            <version>1.4.9</version>
            <exclusions>
                <exclusion>
                    <groupId>org.apache.httpcomponents</groupId>
                    <artifactId>httpclient</artifactId>
                </exclusion>
                <exclusion>
                    <groupId>org.apache.httpcomponents</groupId>
                    <artifactId>httpcore</artifactId>
                </exclusion>
                <exclusion>
                    <groupId>org.apache.httpcomponents</groupId>
                    <artifactId>httpmime</artifactId>
                </exclusion>
            </exclusions>
        </dependency>

        <!-- https://mvnrepository.com/artifact/javax.ws.rs/javax.ws.rs-api -->
        <dependency>
            <groupId>javax.ws.rs</groupId>
            <artifactId>javax.ws.rs-api</artifactId>
            <version>2.1.1</version>
            <scope>provided</scope>
        </dependency>
        <dependency>
            <groupId>org.apache.poi</groupId>
            <artifactId>ooxml-schemas</artifactId>
            <version>1.4</version>
            <scope>compile</scope>
        </dependency>
        <dependency>
            <groupId>org.apache.poi</groupId>
            <artifactId>poi-ooxml</artifactId>
            <version>4.1.2</version>
            <scope>compile</scope>
        </dependency>
    </dependencies>

    <pluginRepositories>
        <pluginRepository>
            <id>atlassian-public</id>
            <url>https://m2proxy.atlassian.com/repository/public/</url>
            <releases>
                <enabled>true</enabled>
            </releases>
            <snapshots>
                <enabled>true</enabled>
            </snapshots>
        </pluginRepository>
    </pluginRepositories>

    <build>
        <plugins>
            <plugin>
                <groupId>com.atlassian.maven.plugins</groupId>
                <artifactId>jira-maven-plugin</artifactId>
                <version>8.1.0</version>
                <configuration>
                    <!-- <enableQuickReload>true</enableQuickReload> -->
                    <jvmArgs>-Xms512m -Xmx1g -XX:MaxPermSize=1g -XX:-UseGCOverheadLimit -server</jvmArgs>
                    <productDataPath>${basedir}/src/test/resources/generated-test-resources.zip</productDataPath>
                    <!-- <systemPropertyVariables>
                        <plugin.script.roots>${project.basedir}/src/main/groovy</plugin.script.roots>
                    </systemPropertyVariables> -->
                    <applications>
                        <!-- Uncomment these if you wish to include them -->

                        <!-- Include Jira Software features -->

                        <application>
                            <applicationKey>jira-software</applicationKey>
                            <version>${jira.software.version}</version>
                        </application>

                        <!-- Include Jira Service Desk features -->
                        <!--
                        <application>
                            <applicationKey>jira-servicedesk</applicationKey>
                            <version>${jira.servicedesk.version}</version>
                        </application>
                        -->
                    </applications>
                </configuration>
            </plugin>
        </plugins>
    </build>

    <repositories>
        <repository>
            <id>nexus-public</id>
            <url>https://nexus.lending.fcc.ca/repository/public/</url>
            <snapshots>
                <enabled>false</enabled>
            </snapshots>
            <releases>
                <enabled>true</enabled>
                <checksumPolicy>fail</checksumPolicy>
            </releases>
        </repository>
        <repository>
            <snapshots>
                <enabled>false</enabled>
            </snapshots>
            <id>central</id>
            <name>valiantys-public</name>
            <url>https://repository.elements-apps.com/artifactory/valiantys-public</url>
        </repository>
        <repository>
            <snapshots />
            <id>snapshots</id>
            <name>valiantys-public</name>
            <url>https://repository.elements-apps.com/artifactory/valiantys-public</url>
        </repository>
        <!-- This is required to find the parent pom and ScriptRunner dependencies -->
        <repository>
            <id>adaptavist-external</id>
            <url>https://nexus.adaptavist.com/content/repositories/external</url>
            <snapshots>
                <enabled>false</enabled>
            </snapshots>
            <releases>
                <enabled>true</enabled>
                <checksumPolicy>fail</checksumPolicy>
            </releases>
        </repository>

        <!-- This was added but not sure that it is required -->

        <repository>
            <id>atlassian-public</id>
            <url>https://maven.atlassian.com/repository/public</url>
            <snapshots>
                <enabled>false</enabled>
            </snapshots>
            <releases>
                <enabled>true</enabled>
                <checksumPolicy>fail</checksumPolicy>
            </releases>
        </repository>
    </repositories>
    <distributionManagement>
        <repository>
            <id>nexus-release</id>
            <url>https://nexus.lending.fcc.ca/repository/releases/</url>
        </repository>
        <snapshotRepository>
            <id>nexus-snapshot</id>
            <url>https://nexus.lending.fcc.ca/repository/snapshots/</url>
        </snapshotRepository>
    </distributionManagement>

Are you on a corporate proxy?

PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

This is saying your local JDK doesn’t trust the SSL certificate.

This was SSL certificate issue. Resolved by this guide

https://confluence.atlassian.com/kb/unable-to-connect-to-ssl-services-due-to-pkix-path-building-failed-error-779355358.html?_ga=2.14564215.1176767979.1705422623-879152939.1704727554

2 Likes