Forge application doesn't load anymore in JSM portal

Hello,

We have a Forge app which is displayed on the JSM portal issue, in panel and panel-detail module. Our app use Custom UI (and require Forge bridge in our frontend).

Since today, our app can’t load on some instance due to an HTTP400 when calling {instance}.atlassian.net/rest/servicedesk/1/customer/servicedesk-data/forge/context-token with the following response:

{"errors":[{"errorMessage":"The request body is invalid."}],"reasonKey":"sd.api.error.bad.request","reasonCode":"400"}

It seem the connection with the bridge fail. For additional context, the user on the portal is also admin on the instance.

1 Like

OK, we solved our issue and found a curious behavior:

  • Create a new instance
  • Instance is created with “Sample data” project (ITSAMPLE)
  • Move issue from the sample project to a new created JSM project
  • Replace the reporter with the current user

Then, when we try to display the app on the moved issue, it failed. If we create a new issue, it work.

1 Like

So if I read your analysis correctly, this isn’t actually ‘solved’, rather uncovered a fundamental and potentially super nasty problem with Forge permissions not being properly applied to moved issues? That would certainly warrant a high priority FRGE issue in case?