Forge deploy: Manifest validation failed with "Upsert Environment Request body is invalid. Details "

Hi All,

since yesterday around 11:00AM UTC, we are facing issues with Forge deploy. The error message is not really helpful:

  Upload URL is valid
  Found manifest file
  Manifest is a valid YAML
  Manifest validation failed
Validation errors: {
  "validationResult": {
    "tid": "5e1b98eac5d2e550",
    "code": 400,
    "type": "UpsertEnvironmentRequestInvalidError",
    "message": "Upsert Environment Request body is invalid. Details "
  }
}

Error: Deployment failed

Error: Deployment failed
    at ArtifactDeployer.handleErrorEvent (C:\Users\gabor\AppData\Roaming\npm\node_modules\@forge\cli\out\deploy\deployer\deployer.js:151:15)
    at ArtifactDeployer.pollAndCheckEvents (C:\Users\gabor\AppData\Roaming\npm\node_modules\@forge\cli\out\deploy\deployer\deployer.js:61:18)
    at processTicksAndRejections (internal/process/task_queues.js:97:5)
    at async ArtifactDeployer.monitorDeployment (C:\Users\gabor\AppData\Roaming\npm\node_modules\@forge\cli\out\deploy\deployer\deployer.js:72:28)
    at async ArtifactDeployer.deploy (C:\Users\gabor\AppData\Roaming\npm\node_modules\@forge\cli\out\deploy\deployer\deployer.js:36:9)
    at async PackageUploadDeployCommand.execute (C:\Users\gabor\AppData\Roaming\npm\node_modules\@forge\cli\out\deploy\package-upload-deploy.js:14:9)
    at async CommandLineUI.displayProgress (C:\Users\gabor\AppData\Roaming\npm\node_modules\@forge\cli\node_modules\@forge\cli-shared\out\ui\command-line-ui.js:44:28)
    at async DeployView.reportDeploymentProgress (C:\Users\gabor\AppData\Roaming\npm\node_modules\@forge\cli\out\command-line\view\deploy-view.js:50:24)
    at async DeployController.run (C:\Users\gabor\AppData\Roaming\npm\node_modules\@forge\cli\out\command-line\controller\deploy-controller.js:122:27)
    at async Command.actionProcessor (C:\Users\gabor\AppData\Roaming\npm\node_modules\@forge\cli\out\command-line\command.js:76:32)

This affects our whole team. We made no changes to our manifest.yml file. I was able to deploy our app beforehand with the exact same manifest.yml that failed validation an hour later. I updated Forge CLI to the latest version but it did not help.

I’ve searched community topics for the error message above and found that others faced similar problems before, but the fixes to those problems are not relevant in our case.

My questions:

  • Did anything change in Forge’s manifest validation process? If yes, is there a post we can take a look at to see what changed? Maybe it has been announced in advance and I missed it.
  • Can you provide more meaningful error messages in general? “Manifest validation failed” followed by a cryptic validation result JSON is not helpful. In my team we all faced the same problem and wasted quite some time individually before realizing this is a generic problem and not some awkward individual issue.

@Atlassian Staff I can send our manifest.yml in PM if it helps.

Thanks,
Gabor

7 Likes

Same error for me too.

I haven’t upgraded to forge/cli 4.2.0 (still on 4.1.1) and it works for me… for now.

We think it doesn’t depend on the Forge CLI version, or at least happens with multiple versions:

  1. One team mate used 4.0.6 when the problem occurred and he hoped that the version upgrade could help, but it didn’t.
  2. For another team mate, it also fails with 4.1.1, unfortunately. :confused:

(In total, we know about 3 different Forge CLI versions with this defect.)

1 Like

Hi all,

Thanks for raising this issue here. We are currently treating this as an incident and are getting the team online to investigate this. We will post an update here as soon as we know more.

Colin

3 Likes

Can you give us a link to the incident?

1 Like

The link to the incident is the following one: Atlassian Developer Status - Users unable to deploy Forge apps

Also, it would be best if someone affected by this issue could create a DEVHELP ticket by using the below link, so that we can ask for data/info that will help with the investigation but that’s not a good idea to share in a public forum:

2 Likes

DEVHELP ticket: Jira Service Management

A fix has been deployed and it is now being tested.

We will update this thread as soon as we get confirmation the issue is solved

The incident has been resolved. We’ve updated the status page.
Sorry for inconvenience :bowing_man:
Atlassian Developer Status - Users unable to deploy Forge apps

1 Like

Thank you for the fix!