Forge install --upgrade : Principal has insufficient permissions

Hi Everyone, I’m trying to update/upgrade my forge app but I got this error :

Error: Authorization failed: Principal has insufficient permissions

I already double-checked that my account is in administrator group and has the permissions.

Anyone can help?

Thank you,

1 Like

This is also happening to me. I tried creating a new API token, which I’m able to login with using forge login. But still no luck with forge install --upgrade. I’m able to run forge deploy just fine…

Forge is great in theory but these random regressions that pop up really make you want to pull your hair out…

After contacting the support, I managed to solve the issue by manually upgrading the app from the admin page (manage app). But yeah, I’m still facing that issue until now

Has anyone figured a solution or workaround? I can’t seem to find any way to “manually upgrade” my Forge apps in the Developer Console either.

Seeing this as well, previously deployments worked and the api token says it was accessed during deployment attempt but I’m getting this error.

I still have the same issue… My thoughts: the current logged in user from ‘forge whoami’ does not have permissions on the site(s)