Forge login using API token shows "Your response is needed to continue"

Hi everyone,

I try to login using forge login command, with my email and API token.
It works at the first time, but after I call forge logout and try to log in again, it shows “Your response is needed to continue”.

Something I tried:

  1. I tried on a different machine, still the same.
  2. I enable the atlassian two-step verification, still the same.

My environment
My Atlassian account is created by linking a google account, not sure if this will be an issue.
I am on windows and using nodejs version 16.14.0

Thank you in advance.

1 Like

Hi @KyleLiu. Welcome to the dev community. So, it’s not some edge case bug related to 16.14.0 because I just tried on that version and it worked just fine. I also authenticated with a non-Google account and a Google-based account, and didn’t have a problem. That all being said, I am on Mac (not a PC).

The only time that error should show up is when the CLI doesn’t receive any content in the API token field. Perhaps your paste isn’t working properly in your terminal. Can you try typing in some text (not pasting) that isn’t an API token to see if you receive the following error message?

Error: We couldn't log you in with those credentials. Check your email address and token before rerunning the command.

1 Like

Try using Windows PowerShell instead of the Command Prompt to perform the commands. I had the same issue and this solved it. @nmansilla is correct, the error has to do with the Paste function not working properly in Command Prompt.

2 Likes

Thank you for your reply~
I found out the issue was so simple, the issue is the token was not pasted in to command line.
I use ctrl+c ctrl+v for windows cmd, and figure out it was not doing the pasting, so I try right-click in the cmd, and it works.

2 Likes

i got this error when i tried to paste my token:
Error: We couldn’t log you in with those credentials. Check your email address and token before rerunning the command.

This solved it! wow I tried all things lol.

You can enter email and token parameters
forge login --email <email> --token <token>
it worked for me