Forge tunnel EACCES: permission denied, open 'manifest.yml'

I’m authenticated with forge login and can run forge deploy without problems.

forge tunnel --verbose

fails with the following

Tunnel redirects requests you make to your local machine. This occurs for any Atlassian site where your app is installed in the development environment. You will not see requests from other users.
Press Ctrl+C to cancel.

Checking Docker image... 100%   
Your Docker image is up to date.

Error: EACCES: permission denied, open 'manifest.yml'

Error: EACCES: permission denied, open 'manifest.yml'
    at Object.openSync (fs.js:462:3)
    at Object.readFileSync (fs.js:364:35)
    at FileSystemReader.readFile (/tunnel/node_modules/@forge/cli-shared/out/file-system/file-system-reader.js:19:33)
    at ConfigFile.readConfig (/tunnel/node_modules/@forge/cli-shared/out/config/config-file.js:33:54)
    at ConfigFileSectionReader.readConfigSection (/tunnel/node_modules/@forge/cli-shared/out/config/config-file-section-reader.js:11:48)
    at ShapedConfigFileSectionReader.readConfigSection (/tunnel/node_modules/@forge/cli-shared/out/config/config-file-section-reader.js:32:41)
    at AssertiveConfigSectionReader.readConfigSectionOrThrow (/tunnel/node_modules/@forge/cli-shared/out/config/config-section.js:15:60)
    at StartTunnelCommand.getAppConfig (/tunnel/node_modules/@forge/cli-shared/out/apps/app-config.js:20:101)
    at StartTunnelCommand.execute (/tunnel/node_modules/@forge/tunnel/out/tunnelling/command/start-tunnel-command.js:66:42)
    at Object.exports.runTunnel (/tunnel/node_modules/@forge/tunnel/out/index.js:31:49)
    at Object.<anonymous> (/tunnel/node_modules/@forge/tunnel/out/index.js:41:9)
    at Module._compile (internal/modules/cjs/loader.js:999:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
    at Module.load (internal/modules/cjs/loader.js:863:32)
    at Function.Module._load (internal/modules/cjs/loader.js:708:14)
    at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:60:12)

I checked and no application has the manifest.yml file open. Additionally, the user I am running forge tunnel with is in the docker group on my machine.

Any ideas on what is causing this?

@KeianKaserman,
Welcome to the Atlassian Developer Community!
Have you checked whether you/user running forge tunnel have right permissions to open this file. Depend on your project setup may be this is on a mount/volume with restricted access ?

If that doesn’t help may I know whether you are following any guide to create this project ?

Hi Lashani,
Thank you for the response. I run forge tunnel as the same user that owns the manifest.yml file. I don’t think it should be an issue with permissions to the file.

To answer your second question: I was following the Forge Jira hello world tutorial when I ran into this error.

Hi @KeianKaserman ,
Could you also please check whether your docker setup has right permission to access the files in your project location?
Also as mentioned in Forge Jira hello world tutorial ,
Note, the forge tunnel command only forwards traffic when the user in Jira or Confluence matches the Forge CLI user. For security reasons, you can’t see the traffic of other users.