Forge tunnel error: Cannot pull the tunnel image

Hello everyone,

I am having trouble to get the forge tunnel command to work.

I followed the tutorial (https://developer.atlassian.com/platform/forge/build-a-hello-world-app-in-confluence/) and when it is time to use the command I get the following message:

Tunnel redirects requests you make to your local machine. This occurs for any Atlassian site where your app is installed in the development environment. You will not see requests from other users.
Press Ctrl+C to cancel.

Checking Docker image... failed   
Cannot pull the tunnel image.

I should note I am using WSL 2 (Ubuntu) and podman (my organization does not allow docker, although I can pull images from dockerhub regularly)

I was wondering if anyone here had encountered the same issue.

Thank you in advance!

Do you have any firewall restrictions in place? Wonder if the command is trying to get at a resource hosted somewhere that you haven’t added to an allow list.

I ended up being able to use the tunnel when I tried with a different wi-fi connection (after trying everything else!), so I am guessing you’re right, it most likely was a firewall issue. Thank you for your answer!

1 Like

@DanielFranco how did you get Forge Tunnel working with podman? I tried setting up an alias with docker but that didn’t seem to work. Were there any special steps you took?

EDIT: Also tried symlinking /usr/bin/podman to /usr/bin/docker. Forge at least finds the docker command now, but I’m now getting the same error as you: Cannot pull the tunnel image. I can pull from Docker Hub just fine, and have logged in, so not sure what the issue could be?