Forge tunnel error: The manifest.yml file is not a valid YAML

tl;dr: forge tunnel gives me the error “The manifest.yml file is not a valid YAML. Fix it and try again.” while forge lint found no issues, and forge deploy is succeeded.

Hi, I got the error The manifest.yml file is not a valid YAML. Fix it and try again. when I run forge tunnel. But my manifest file is totally correct, forge lint gives me no issues, and I can run forge deploy without any problem.

I’m using Windows 10, Forge CLI version 1.3.0. Below is the screenshot with --verbose flag:

Hmm, it works again somehow.

I restarted the Ubuntu WSL2 in my Windows system: wslconfig /t Ubuntu-20.04 (reopen Ubuntu after this command), and my forge tunnel works again, I don’t know if the Ubuntu restarting really help here, or I have lucky from something else.

But one thing I don’t understand is: I run forge tunnel directly from Windows cmd, not from Ubuntu shell, but I got this message from Docker Desktop:
image
So what is happening in the background, does Atlassian shared something from Windows into WSL2, and how did it cause my problem?

Hello :slight_smile:
I think what happened here is that Docker started properly but was not able to share files with your system (Ubuntu <-> Windows).
This means that the Tunnel, when started, could not find the needed files related to your app (ie, no manifest detected).
Of course, your app has all those information locally, so the forge lint command works as expected.
Restarting the wsl fixed it as it allowed Docker to properly share files with your system, hence was able to load the Forge app files.

Hi @XavierCaron, the problem happens again today. There is no way to make forge tunnel work, could you please support here?

Edit: Another solution found.

Restart the Ubuntu did work on the day, but not work for today. So I tried to restart the Windows Subsystem for Linux and it fixed the problem:

What I did:

  1. Quit Docker
  2. Open Powershell as Administrator and run Get-Service LxssManager | Restart-Service