Forge tunnel not working with Custom UI React app

Hi i cannot display my localy hosted app on developer site.
In my terminal where i run forge tunnel i get the following message, when requesting the projectPage, where the Custom UI app should display.

Received proxy request. Serving file index.html for resource asdasd from specified address http://localhost:3000

Anny suggestions what is wrong?

My manifest:

modules:
  jira:issuePanel:
    - key: asd-hello-world
      function: main
      title: asd
      icon: https://developer.atlassian.com/platform/forge/images/icons/issue-panel-icon.svg
  function:
    - key: main
      handler: index.run
  jira:projectPage:
    - key: jira-projectPage-example
      title: 'Example'
      icon: https://cdn-icons-png.flaticon.com/512/1250/1250680.png
      resource: asdasd
      layout: basic
resources:
  - key: asdasd
    path: static/issue-connector/build
    tunnel:
      port: 3000
app:
  id: ari:cloud:ecosystem::app/e109715a-ae62-415d-86b2-825d8257ae4e

Hi thanks for waiting.

I’m not too familiar with proxying requests for Custom UI. Usually more familiar with the serving files flow.
I’ll try and get some eyes from the team that works on this.

Hi @MszrosPatrik, this message is expected as you have the tunnel setting in your resources definition. The explanation for the proxy request is in this documentation

Once a port has been added to a resource definition, running forge tunnel causes the Forge CLI to bypass the path directory, and instead proxy the request to http://localhost:<port>

I’m not quite sure what issue you’re facing, the resources not loading at all or having some error on it? Could you please try connecting to your dev server http://localhost:3000 and see if the static resources can be loaded correctly?

If the dev server is working as expected, some screenshots of your app and console log errors (if any) would be much appreciated to help us investigate the issue.