Forge UI Kit Colors not showing


I’m working on a Compass Forge app with the UI Kit and want to change the primary color of an icon, but for some reason I’m just not getting the colors to work.

This is my component <Icon glyph={icon} size="small" label={build.result} primaryColor={color}/>
And I have tried the following color values, success, color.icon.success, and even elevation.surface.sunken since that background color does seem to work on a Box component using xcss

However the icons never change in colour, always showing the text color.
Screenshot 2024-07-03 at 19.31.15

I have also tried wrapping the Icon in a Box and using xcss to change the text color, but that also doesn’t work.

What am I missing?
To make it extra strange, using the elevation.surface.sunken token for the background of a Box does work without issue.

I also tried adding this to the permissions element of the manifest with the same result

    - 'unsafe-inline'

I solved this by wrapping the Icon component in a Box component so I can use XCSS to set the text color.