Hints and tricks to get custom ui tunneling working for Forge?

I’m trying to get the custom ui tunneling working properly (I have been for a while now). Late last night I was able to get firefox to handle it by disabling compression on the requests. However that doesn’t seem to work today (I know the docs says that Chrome is only supported - but I can’t seem to get Chrome working either).

So - anyone have any tips?

/Daniel

4 Likes

@danielwester are you running a local dev server for your SPA app? By running my react app on port 3000 (default if you’re using a Forge template), I can tunnel. This is how the manifest should look:

resources:
  - key: main
    path: static/spa/build
    tunnel:
      port: 3000

Yep. That’s what I’ve got. I believe it has something to do with the headers that are sent down to the SPA. Like I said - if I switched to firefox I could disable the compression headers from being sent down. However that doesn’t seem to work anymore…

Is there any debugging or something that I can do or am I just out of luck?

Digging into things - if I disable the compression of a CRA app - then tunneling works. Not really the workaround that I want to have (tested on a brand new CRA app).

Everything seems to point to that whatever dark magic is happening on port 8004 (or the other custom ui tunnels) is doing a pass through of the headers but decoding of the body which just causing things to be unhappy (or at least that’s the curl error I’m getting).

2 Likes