How can I see the generated descriptor for the Forge Connect companion app?

Trying to finish things up for Codegeist but for some reason the modules that I’m relying on from the Forge/Connect companion app isn’t made available to me. Is there any way for me to see what the generated descriptor is?

1 Like

Hi @danielwester ,

So sorry I didn’t see this sooner - I’m now subscribed to the forge-connect tag in the hopes I spot this sooner, next time.

No descriptor is generated; instead Connect fetches the forge modules and translates them into its own module format without an intermediate connect descriptor coming into play. I’m happy to help you debug if there’s something you can share with me, like your app manifest.

So are you saying the modules don’t show up at all, or there’s somewhere you’re querying for a list of modules and connect-on-forge ones aren’t among them?

I had a set of custom types set up in the manifest for a confluence app. Before I upgraded to 2.0 - it worked - I could create the custom content by referencing the app key and the content type’s key. After I upgraded to 2.0 - it’s like the custom content modules aren’t loaded into the system (the rest api in confluence says they aren’t there). The workaround for me (for now - during development) is to whack the connect modules and then create my own “companion app” in connect with the custom content listed.

I’m not sure if it’s caused by the same issue as my Context is Jira instead of confluence, but I tried to follow the bitbucket example yesterday. Just like danielwester it did seem like the connect modules are not loaded as I couldn’t get the web items to show.
In addition to the “jira:generalPages” in the example I tried to get a webItem to show, which looked like this

  "jira:lifecycle": [
    { "key": "connect-lifecycle", "installed": "/installed" }
  "jira:webItems": [
      "context": "product",
      "location": "jira.project.sidebar.plugins.navigation",
      "url": "/show-projects",
      "key": "my-summary-web-item",
      "name": {
          "value": "My Summary"

Hi, thanks for the reports and sorry for the trouble you’re experiencing with connect modules on Forge. We’re investigating this now. You can follow this ticket for updates.

Please see the public issue for an update. It includes a workaround, which is to let us know your app ID so we can let you know your app’s randomly-generated key, in order to set app.connect.key to match.