How do I know which SDK Versions supports which JIRA Version?

Dear Community,

I am sure, that I just don’t unterstand the concept behind all them, perhaps you can help me.

Current situation: I’ve upgraded my SDK to 8.0.16. I’ve expected, that it would replace my previous SDK but now, I have to SDKs on my machine. But anyway, so far so good. I redirected my system variables to the new SDK and everything seems to be fine.

This website

says, that SDK 8.0.16 allows me to develop Plugins for Jira Server 8.2.1. First question: what about Jira 8.3.1? Is there always a delay between new Jira Versions and new SDK versions? Second question: how often do you update your SDK?

Next step: I edited my pom.xml to make clear, that I want to use a different Jira Version. What about amps.version? I’ve learned that amps.version is always the version number of the SDK? Is that true? In my case it is not. amps.version says 6.3.21 while my SDK version is 8.0.16.

Okay. I changed <jira.version> to 8.2.1. The maximum version which is supported by the SDK. I leave the amps.version at 6.3.21. The result is, that I get different errors. For example:

Compilation failure
/.../webpanel/ProjectQualityGatesAction.java:[148,34] cannot access javax.servlet.http.HttpServletRequest
  class file for javax.servlet.http.HttpServletRequest not found

Okay, maybe there are some changes at HttpServletRequest? I tried to find out, but the website

https://docs.atlassian.com/software/jira/docs/api/8.2.1/

says, that the function/packages which I use are still the same. So why do I get an error? Am I doing right to check the docs/api website to find out if something has changed? Is there a better website?

Anyway. I changed my pom step by step back till jira version 8.1.2. That’s the last version everything is fine. Atlas-run starts without any problems. Why? What is the reason? Why 8.1.2?

The mentioned error is just an example. I just want to understand the construct of different versions, which do work and why some do not work.

I hope you can help me. :slight_smile:

Hey there,

I can’t answer the first two questions.

But I think I can help you, with the amps.version. We are building an add-on vor 7.8.0 and 8.x.x. When I upgraded my SDK, it was in the same Path as before and had the “old” Version number in its name. If u

atlas-version

in Terminal it will show you the AMPS Version.

We always use this version for any Server version.

And for a little bit easier handling, read into Maven Profiles.

Hope it helps, for any further questions, feel free to contact me.

Have you try this to resolve the error with ‘javax.servlet’?

https://developer.atlassian.com/server/framework/atlassian-sdk/compilation-failure-package-does-not-exist/