How to add a watermark to all pages

How to add a watermark to all pages

Hi @jiangwubo,

Can you please elaborate on what you need and are trying to do?

Your current question has no context (Product, Version, Deployment,…)

Providing more information will not only help you find an answer but will also help people with similar problems in the future.

Cheers,
Peter

1 Like

I want add watermark in all page by custom plug way.

I’m sorry but that is still not enough information.

Are you working in Confluence Server or Cloud? (I’m assuming you’re talking about Confluence based on the fact that you are talking about pages).

Do you want this watermark to be on the pdf export or on the page in the browser itself?

Can you give an example of what you mean by watermark?

If you don’t give us more information I’m afraid we can’t really help you.

I working in Confluence Server.
I want watermark on the pages in the browser.
I want custom infomation of watermark, contain username and more.

Hi @jiangwubo

Maybe one of these solutions can help you out:

Cheers,
Peter

1 Like

very good, Thank you.

How to display a watermark in export pdf or more?

Please take a look here: https://community.atlassian.com/t5/Confluence-questions/Confluence-PDF-export-with-watermark/qaq-p/12457

That should help you out.

I want export pdf via page -> exports pdf or export word,
not via space Tools > Export to PDF

Normally the changes you make for the full export should also work for the per page export to pdf.

Where is the layout of the mobile phone page?

I’m sorry but I have no idea, I do know that there are known limitations on the mobile app: https://confluence.atlassian.com/doc/using-the-confluence-server-mobile-app-947169252.html

The Header/Footer options are not included in the single-page export:
https://confluence.atlassian.com/doc/advanced-pdf-export-customizations-198806890.html#AdvancedPDFExportCustomizations-AddingHeadersandFooterstoSinglePageExports

Why can’t I open these pages?

Hey @chenkaiyin1201,

I just checked both links in incognito mode and they work fine for me.
So I don’t know why they wouldn’t work for you.

Cheers,
Peter