How to change jira version in pom.xml file

Hi ,

When i use command : atlas-create-plugin then the following is executing as below

And after the plugin folder created , In pom.xml , jira version value is also showing the same(it is 7.13.0)

When I try to change version to jira 8.5.0 , I’m getting a error as

Dependency ‘com.atlassian.jira:jira-api:8.5.0’ not found

This below line is showing error
version>${jira.version}

can anybody please help me

Please provide a step by step procedure regarding how to modify jira version in pom.xml file.

Thanks & Regards,
Rahul Jodavula.

Hi,

You should let the version in the pom.xml on the version of the lowest Jira version you want your app to be compatible against. This version indicates the API version your app is compatible to.

Then you can simply run any version above that range via:

atlas-run --product jira -v 8.5.3
1 Like

Hi ,

Thank you very much for the update

Okay I got

So let my version in my pom.xml be the same as below ,’

image

but when i run my atlas-run , we can use atlas-run --product jira -v 8.5.3

Does it work ? I mean when i run the above command does it install a jira with 8.5.3 version and plugin compatible with it ?

Okay if the above method works , How can i generate a jar file of that plugin which is compatible with respected jira version (ex-: 8.5.3) ?
As of now i’m using "atlas-mvn package " command to generate a jar file of the plugin in target folder .
after that i’m uploading that jar file in jira manage apps section .

Can i generate a jar file of plugin for respected jira version ?

Thanks in advance .

Hi,

which version of the SDK do you use (see https://marketplace.atlassian.com/apps/1210950/atlassian-plugin-sdk-windows/version-history)?

With a current SDK version changing jira.version should do the trick.

    <properties>
        <jira.version>8.5.0</jira.version>
        <amps.version>8.2.0</amps.version>

Hi, sorry got no notification on your reply.
So your app.jar will be compatible 7.13.0 and up. So also against Jira 8.x (there are some strange things different in AUI between Jira 7.x and 8.x, and some other very special things, but you should be fine)

You have properties>jira.version=7.13.0
When you then run “atlas-package”, the JAR file will be compatible to 7.13.0 and up. But I recommend you to test it on every version at least if Jira starts up with your app installed.

So I would do something like:
atlas-run --product jira -v 7.13.0
atlas-run --product jira -v 8.0.0
atlas-run --product jira -v 8.1.0
atlas-run --product jira -v 8.2.0

atlas-run --product jira -v 8.14.0

At best automated in some CI Server. But you will only need that if you publish your app on the Marketplace. If you simply use it internally in your own Jira, just keep it up to date to the Jira Version you are actually using. So if you upgrade once to Jira 8.14, then some time after you can update your code to properties>jira.version=8.14.0

So it depends :slight_smile:

TL;DR: in short, your App is compatible to the minimum version of what you specify in the pom.xml and is potentially endlessly upwards compatibly (unless Atlassian introduces some breaking changes in e.g. Jira 9 or so, which is very very seldom)

Hi ,

Actually i want to run this command to run “atlas-run --product jira -v 7.13.0” but the problem is after running this below is executed in command prompt.

But unfortunately jira is not accessible and with below msg

Status : 404
the origin server did not find a current representation for the target resource or is not willing to disclose that one exists after running atlas-run command jira

i’m accessing using url http://localhost:2990/jira/

the error is same as error occured in below

Diffference is i got it for jira and he got it for confluence .

As he mentioned i could access GET /cargocpc/index.html created in target folder
but not GET/jira/

first you have to change the version of atlassian sdk to be compatible with the desired jira version ( forme mor informations check Atlassian Plugin SDK - Windows - Version history | Atlassian Marketplace)
second, you have to change java-version and amps-version in the pom (to know amps version just excute ‘atlas-version’ and it will give you the amps version)