How to disable speech recognition in rich text editor?

Hi There,

I have a requirement to disable speech recognition option available in the rich text editor. Is there any way that we could hide this option from the users? Any advise or guidance would be greatly appreciated…!!

Regards,
Arun

Hi @arun.sasikumar,
thanks for reaching out!

First of all, I’d like to understand why do you need to disable it? What’s that requirement?

Current state-of-the art is that there’s no build-in way of removing Speech recognition item.
It’s visible only in Chrome as it’s the only browser which currently supports SpeechRecognition from Web Speech API.

I look forward to hearing from you!

Best regards,
Maciej
Jira Server Team

Hi @mrzymski,

This particular requirement came as we could see that Speech recognition feature in chrome is indirectly using google’s servers for speech to text recognition ( as quoted here - Google-whitepaper) and it may break our corporate security guidelines.

Regards,
Arun

1 Like

Hi @arun.sasikumar!
Thanks for your explanation. It helps a lot.
I’ll consult our PM what are our plans about this feature and whether it’s feasible to add an switch off option for it.

In the meantime, you can use a workaround:

  1. Hiding the item from the UI (via a userscript or a plugin), e.g. by adding a “hidden” class to the DOM element which has a class .wiki-edit-speech-item.
  2. Removing webkitSpeechRecognition from window object (via a userscript or a plugin).
    An example of UserScript (you’d need to change @match value in order to match your Jira instance).
// ==UserScript==
// @name         New Userscript
// @namespace    http://tampermonkey.net/
// @version      0.1
// @description  try to take over the world!
// @author       You
// @match        http://localhost*/*
// @grant        none
// ==/UserScript==

(function() {
    'use strict';

    delete window.webkitSpeechRecognition;
})();

Best regards,
Maciej
Jira Server Team

Hi @mrzymski

Thanks for the confirmation. I have already tried out the first workaround mentioned and is working fine. I was looking for a perfect solution.

Regards,
Arun