How to fix create-jira-plugin problem?

All,

What I am trying to do:
I am trying to create a simple hello-world JIRA plugin using the following bin provided by the SDK 6.2.15:

atlas-create-jira-plugin

This is the issue I am having:
When I run atlas-create-jira-plugin, the script downloads all these files, but errors out when it tries to download: plexus-utils 3.0.17. Both respositories mentioned below, are missing the folder/file/pom for plexus-utils 3.0.17.

see: Link

How I tried to fix it:

  1. I read and attempted the steps listed under diagnosis
    https://confluence.atlassian.com/jirakb/running-atlas-create-jira-plugin-fails-with-unknown-host-maven-atlassian-com-938026865.html?_ga=2.47129134.882834433.1507229166-1818878504.1506017380
  2. Followed the suggestion:
    https://developer.atlassian.com/docs/advanced-topics/working-with-maven/atlassian-maven-repositories?_ga=2.213724189.882834433.1507229166-1818878504.1506017380

In <atlassian_install>\conf\settings.xml file:
under:
<pluginRepositories>
<pluginRepository>

I have updated the Repository URL from:
https://maven.atlassian.com/repository/public
to:
https://packages.atlassian.com/maven/repository/public
3. Tried this on Linux and Windows
4. I have tried to find/download/add plexus-utils 3.0.17 to file://${env.ATLAS_HOME}/repository and no luck
5. Lots of research + tried other “solutions” to fix this issue

Running out of time/ideas.
Any help would be greatly appreciated.

PS - I tried uploading the maven output, but blocked since I am new user. Please let me know if you would like me to paste the output here (can get ugly). Thanks.