How to get custom field to show up on issue

I’m learning how to work with Forge. I cloned, registered, and installed the Forge-Risk-Assessment example with no problem. I followed the “Usage” section of the README.md file and associated the new field to several screens. But the field doesn’t show up in either new or existing issues.

I know the app is installed in Jira and configured to show on the default screen:

and (another image that I could not show)

The default screen is the one configured for issues, as show in this image that I was forced to delete by the forum.

So why doesn’t this field show when I create or edit an issue?

(Note: I put several images in this topic to show how my project is setup but this form told me that, as a new user, I can only have one issue. So you’ll have to guess what was in the other images. Sheesh.)

1 Like

Hi Mark,

Just to verify, are you using new issue view or the old one? (Forge is only supported on new issue view).

Also, could you please check if it is not visible not only on issue view but also on “Create” issue view (on “Create” view it should be visible as normal text input field)

I see “You’re in a next-gen project” in the lower-left corner so I think it must be the new issue view.

I do not see the new field in the create issue view, either.

The description of that Forge Risk Assessment sample app here https://developer.atlassian.com/platform/forge/example-apps/#risk-assessment-custom-field specifically mentions it can be used in classic projects, so maybe it is not compatible with a next-gen project.

That would be a surprise. This is one of the Forge example apps, running with a test project setup via the Atlassian pages for testing with Forge. The “hello world” example works fine with this test project.

So the story is that only on new issue view forge custom view will work, on the old view (and other views like “Create”) the custom field is visible in its “native” form eg. custom field created by this example app should be visible as string input.

I will try to install it today on my instance to see if it works.

Could you list all the screens the custom field is associated with?

To see the custom field on issue view you need to select “TES: Scrum Default Issue Screen” (where TES is your project name) for scrum view. The same way you would need to select “TES: Kanban Default Issue Screen” for kanban board. This way it should be shown both on issue view with Forge UI kit view and on “Create” screen as text input.

The custom field has access to screens named “Default Screen” and “Resolve Issue Screen” and to a context named “Default Configuration Scheme for Risk Assessment”. Underneath the context name it says “This field will be available on issues of any type in all projects”.

I looked all over and I don’t see how to select “Scrum Default Issue Screen”. Nor can I select “Kanba Default Issue Screen”. Under “Dashboards” on the title line, I tried “Create dashboard” to see if I could create a Kanban dashboard, but there’s no sign of that dashboard type.

Please note that this is a free Atlassian Cloud development site which I created to try out Forge without affecting my project’s “production” Jira and Confluence sites. Perhaps there’s something about this free setup that does not work with Forge custom fields despite the fact that the whole purpose is to allow developers to try out Forge…?

The hello world app does work on this free site. This custom field is the second function that I’ve tried. And I’m stymied.

Maybe I found a clue. When I create an issue, it offers two types: “Epic” and “Task”. Under that, it says “Some issue types are unavailable due to incompatible field configuration and/or workflow associations.”

When I go to Settings/Issues/Issue Types, the only type I see is “Epic”. Under “Issue Type Schemes” I see “(Name) Default Issue Type Scheme - (Options) Epic - (Projects) Global (all unconfigured projects)”. So I figure I need to add the “Task” issue type to the issue type scheme, but I can’t find a way to do it.

Under “Workflows” I see no active workflows or workflow schemes.

I thought maybe I somehow messed up this project, so I created a whole new one and changed nothing. I used the Kanban template and now I am able to configure the field to show up!

I don’t know how the original project got messed up. Maybe because I had previously configured it with the “hello world” example app?

To be honest it is hard to say what happened with the first project, good to hear that you were able to associate the field with the proper screen on the new project and can work with Forge :).

We will anyway investigate further the problem you have on the old project to see what happened.

1 Like