I can't migrate Workflows from Server to Cloud

I’m an app developer and I’m getting some trouble migrating workflows post functions.

We followed this tutorial
We did implement the step 1 on the Server app. We tried the step 2 in both apps (server and cloud) and we did not get any workflows.
We used the namespace mentioned on the tutorial jira/classic:workflowRule. The request works, only this namespace retrieves an empty response.
We only have problems on the Workflow post functions, everything else works.

We also tried to migrate native post functions on a project, and on the Cloud side, the post functions were ignored.

Some extra migrations:
Dark Features: On
Jira Cloud Migration Assistant version: 1.5.6

Do I need something else to make this work?

Best regards,
Rafael Morais

1 Like

Hi @RafaelVideiraMorais,

I’ve had a chat with my colleagues and we’d like to get the code you have in getSupportedWorkflowRuleMappings(). Specifically, please make sure you have the package and class name correct. For example if you have

workflowRules.put("com.vendor.workflow.CloseParentIssuePostFunction", "closeParentIssuePostFunction-cloud");

Then is it com.vendor.workflow or com.vendor.workflows?

If it’s not this, then can you post an example of your getSupportedWorkflowRuleMappings() and also the latest transferId so we can check the logs on our side to see if something else is happening?


1 Like

Hi @jrichards ,
Thank you for the fast reply.

As you asked, I send you the getSupporterWorkflowRuleMappings()

public Map<String, String> getSupportedWorkflowRuleMappings() {
  Map<String,String> maps = new HashMap<>();
  return maps;

The package and class names are correct.

I also send you the transferId: 32440bc9-f3b2-3c52-aaf0-43066989b7e8

Best regards,
Rafael Morais

Hi @RafaelVideiraMorais,

Thanks for the update. We’ve been working on this a bit today and we can confirm that the data should be there.

To confirm, we’re sure that the class names match in getSupportedWorkflowRuleMappings() and that you have the app migration dark feature on.

Finally, you also need to make sure

  1. the post workflow function is associated with workflow
  2. that workflow is in a Project
  3. that Project is being migrated

Hope this helps.


Hi @jrichards,

We have the dark features on and we add more two:

  • migration-assistant.app-migration.dev-mode

  • com.atlassian.jira.migration.app-migration.feature

When we try to get the mappings on the cloud side with the namespace jira/classic:workflowRule, we get a 200 success response, but we get an empty response body:

We tried to migrate a project with workflows post functions and on the Cloud side we only get the 6 default post functions.
We also tried to migrate a project and we add and remove some Jira workflows and on the Cloud side we also get the 6 default post functions.

To conclude, not even Jira post functions are migrated.

Best regards,
Rafael Morais.

Hi @jrichards ,

During today we made some additional tests, and we realize that even the workflows are not being migrated correctly.
Server workflow example:

Cloud workflow example:

Note that we have some differences.

  • The step name is not the same.

  • Transitions did not migrate.

I believe that the reason to get an empty response on the app is related to this issue.

Best regards,
Rafael Morais.

Hi @jrichards ,

We tried other things and we realize that we had a typo in one of the keys.

Thank you very much for your time.

Best regards,
Rafael Morais.

1 Like