Insight external source ingest - nothing happens

Hi, i have followed the workflow as of official documentation

Following the example object type (hard disk, os) and sending the payload, all works fine.
Problems seems to happen for non-default attribute types.

First thing: how can i declare and map attributes that has a particular type? In my case i have defined a User and a Group attribute.
For the Group i have tried in the json to declare it as “select”.
I have to avoid the User type in the json sent to the mapping endpoint to preserve it (object type defined previously using the insight interface).

I have tried the start and submitResult requests several times, the api always return a 200 status code.
On audit logs in insight i can see the number of records involved in the import, but no other useful informations regarding the ingest (no errors, no new object inserted, no record updated).

I guess something regarding the Group and User attribute is involved (others are text, date and boolean), but i’ll wait your response / example.

I have tried to omit the user in the payload and also to pass the accountId value, for the Group i have tried to send an array of strings of real groups defined in my cloud instance (e.g [‘aministrators’,‘jira-admins-…’]

Hi @michelegranato,

The external import APIs do not currently support User or Group type attributes. Only the “default” attributes and Object reference attributes are supported at this time.

There is a feature request to add this functionality that I encourage you to add a comment to with your use case [JSDCLOUD-10732] Add support to User type attributes on External Import - Create and track feature requests for Atlassian products.

It’s something the team is aware of and working on prioritising.


1 Like

thanks for the clarification. yes i saw that doing some researches, so the situation is still stuck at that point.

going to vote on that