Installation failed. The app defined an unknown module (blueprints)

blueprint

#1

Hi,

I’m trying to create Blueprint atlassian-connect add-on. So I took example here but took “Installation failed. The app defined an unknown module (blueprints).” error when uploading the app to my Confluence cloud instance.

I’d appreciate any help you can give me. Thanks in advance.

Here is my atlassian-connect.json :

{
  "key": "confluence-multipage-blueprint-example",
  "name": "Confluence Multi-page Blueprint Example",
  "description": "Create multiple pages with control over the structure",
  "vendor": {
    "name": "Atlassian Labs",
    "url": "https://www.atlassian.com"
  },
  "baseUrl": "${addon.base-url}",
  "links": {
    "self": "http://localhost:3000/atlassian-connect.json",
    "homepage": "http://localhost:3000/atlassian-connect.json"
  },
  "authentication": {
    "type": "jwt"
  },
  "lifecycle": {
    "installed": "/installed",
    "uninstalled": "/uninstalled"
  },
  "scopes": [
    "READ",
    "WRITE"
  ],
  "modules": {
    "blueprints": [
      {
        "template": {
          "url": "/blueprint.xml"
        },
        "createResult": "edit",
        "key": "remote-blueprint",
        "name": {
          "value": "Simple Remote Blueprint"
        }
      }
    ],
    "webhooks": [
      {
        "event": "blueprint_page_created",
        "url": "/created"
      }
    ]
  }
}

#2

Hello @driver, this error occurs when you install the app in a non-confluence product. I experienced the exact error before when I accidentally removed /wiki in the UPM URL (<baseUrl>/wiki/plugins/servlet/upm) when installing it manually which made me access Jira’s instead.

I tried the sample code and I was able to install it just fine in my instance just now. If you are manually installing it via UPM (if you cloned the bitbucket repo and did not add credentials.json), kindly make sure that you’re currently in Confluence. If you created a credentials.json (as mentioned in the latter part of the tutorial), kindly make sure that the product you’re targeting is confluence.

If both of the scenarios I mentioned is not the one you’re facing and you’re still experiencing problems, kindly add a screenshot of the error.

Thanks,
Ian


#3

Hi Ian,
Yes, I tried to install it manually. It seems I had the same error - accidentally removed /wiki in the UPM URL.
Thanks a lot.