Installation fails after enabling SSL


In our addon we’ve enabled SSL connection on Heroku and since then we can’t install our app in Jira instance. Route /installed (handled by ACE) fails due to timeout. We changed our local docker environment to also use SSL and it’s the same - “The app host did not respond when we tried to contact it at “” during installation (the attempt timed out). Please try again later or contact the app vendor.”

Does ACE require some additional configuration to make it work? Since this endpoint is handled by ACE I have problems debugging the issue. Any help appreciated.

Hi, I had similar problem and I needed to tweak config.json.
Try to add:

"dialectOptions": {
        "ssl": {
          "require": true,
          "rejectUnauthorized": false

Thanks. I’ve tried that but it’s not helping. I’m still getting things like this in my logs and it’s not working

no pg_hba.conf entry for host "", user "...", database "...", SSL off

Any idea if there’s something I could’ve missed in my configuration? It all worked fine without SSL.

I have found the issue. Yes, the config has to be properly set like in the example above but also we had outdated ACE version (we had 4.0.1) ACE from version 4.2.0 up uses dialectOptions from config.json.

1 Like