Is the Atlassian Connect tutorial broken?

I have a lot of experience developing desktop applications and administering Jira. I want to now combine those skillsets, but the simple helloworld tutorial seems to be failing. I am not sure if its something I am doing incorrectly though. Here is the tutorial I have been following: https://developer.atlassian.com/cloud/jira/platform/getting-started-with-connect/

No issues in getting my environment set up or installing any of the packages, but when trying to open the ‘Greeting’ app, the page is stuck loading until it gives a generic “Atlassian has been notified, please reload” error. Opening the browser console, I am noticing this error:

https://e31f-73-66-108-24.ngrok-free.app/newhelloworld.html?xdm_e=https%3A%2F%2Fmysite.atlassian.net&xdm_c=channel-com.example.myapp__new-hello-world&cp=&xdm_deprecated_addon_key_do_not_use=com.example.myapp&lic=none&cv=1001.0.0-SNAPSHOT

(changed info in that snippit, but the ngrok link appeared to work fine)

I am really lost on this one and would love to be able to start working on my ideas. I know this is a beginner level issue, but I would greatly appreciate some help on this.

Edit: Additionally, I tried this tutorial to use ACE, which I don’t understand the drawbacks of using, but sadly it still doesn’t work for me. Getting the same error Build a Jira app using a framework

1 Like

Hi @JordanBerry,

This error appears if the ngrok authtoken is not set properly. Depending on your OS, the ngrok.yml should be located in:

OS Location
Linux and MacOS ~/.ngrok2/ngrok.yml
Windows C:\Users\<Username>\.ngrok2\ngrok.yml

This file should contain something like

authtoken: <ngrok_auth_token>

You can manually create this file or call the ngrok command from inside your project directory’s<project_directory>/node_modules/ngrok/bin. In my case it looks like

% ./ngrok authtoken <ngrok_auth_token>
Authtoken saved to configuration file: /Users/iragudo/.ngrok2/ngrok.yml

Other relevant resources:

Hope this helps and let us know how it goes.

Ian

2 Likes

Hey Iragudo,

I got the first tutorial working, but still have some issues with it pulling the updated version. To do this would you just stop the tunnel, uninstall the app, update code, retunnel and reinstall? My ngrok.yml was in the correct area, I think my issue was when I started the http-server I did it outside of my project directory.

Do you have any idea why the Atlassian Connect Express tutorial would not work, if the ngrok.yml was in the correct place, and I ran ‘npm start’ from the project directory?

edit: Nevermind, I realized it was still starting up a free tunnel, so I visited the temporary site and did the click through and it worked!

2 Likes