Issue with Jira Api when fetching data in browser

i have an issue while fetching data from API (/rest/agile/1.0/board/…).
I’m using a fetch in a React App:

const encodedstr = process.env.REACT_APP_JIRA_API_TOKEN;
    const url = process.env.REACT_APP_JIRA_URI;
    fetch(url ?? '', {
      method: 'GET',
      headers: {
        Accept: 'application/json',
        Authorization: `Basic ${encodedstr}`,
      .then((response) => {
        return response.json();

And i’m getting a 426 http error code.
For more context the Auth is the b64 of “useremail:userToken” of an authorized user and this auth is working on Postman and with curl
The URL i’m calling in front is{the filters that i need to use} and i got a nginx proxy running on the server who got the proxy pass and proxy redirect props to get the part of the URL after the /jira/ and put it in another request calling{the part that i got from the proxy redirect & proxy pass}

For more context i did it that way to not get a CORS error and that was working fine from january 2022 to the start a june 2022.

As i said earlier the fetch is working fine in cUrl req and with Postman but i’m getting a 426 when i use it in the browser.
So i tried to force TLS1.2 in my proxy config but i still got the same error and i even tried to use different fetching libraries in front (Js vanilla fetch, Node-Fetch and Axios).

I have no clue on where to go next so if anyone as an idea on how to get this fixed i would love to hear it.