JIRA Plugin SDK not working

I just downloaded the Windows SDK 6.3.4. Verified the install with ‘atlas-version.’ But when I run ‘atlas-create-jira-plugin’ I get a build failure, seems that it cannot find:

Downloading: http://repo.maven.apache.org/maven2/com/atlassian/maven/plugins/maven-jira-plugin/6.3.6/maven-jira-plugin-6.3.6.pom
[WARNING] The POM for com.atlassian.maven.plugins:maven-jira-plugin:jar:6.3.6 is missing, no dependency information available

I go to the website: http://repo.maven.apache.org/maven2/com/atlassian/maven/plugins/maven-jira-plugin/ and the only folder in there is:

5.0.18/                                           2015-03-18 06:13         -      
maven-metadata.xml                                2015-03-18 06:14       354      
maven-metadata.xml.md5                            2015-03-18 06:14        32      
maven-metadata.xml.sha1                           2015-03-18 06:14        40      

Is the folder for 6.3.6 really missing???
Earlier this week I tried following the tutorial v6.2.15, and got it at least create the plugin, but when I did ‘atlas-run’ JIRA was not able to start up, I believe due to missing dependencies. This experience has been frustrating to say the least.

I’ll answer my own question as a colleague helped me solve it:
I had to edit C:\Applications\Atlassian\atlassian-plugin-sdk-6.3.4\apache-maven-3.2.1\conf\settings.xml
and uncomment the “localRepository” tag from:

  <!-- localRepository
   | The path to the local repository maven will use to store artifacts.
   | Default: ${user.home}/.m2/repository

to reflect: