Jira Plugin works on 2990 port but when tested on 8080 port the CSS/JS and Images fail to load

We have developed a Jira Plugin that works perfectly fine on 2990 Port (Dev Environment ), but when we Upload plugin on JIRA server (Managed apps > Upload app > choose file > select project jar file)Jira Server(8080) port the CSS/JS/Images/Fonts/Icons doesn’t load at all .

We have tried the following workaround.
A) In atlassian-plugin.xml,
CSS as resource type=“download” name=“Test.css” location=“css/Test.css”
JS as resource type=“download” name=“Test.js” location=“js/Test.js”

In VM, we tried all combinations as below

In Servlet, we have included the below as per the instructions in web resource module

Context, we have tried both the context
context… jira.general —close context
context… atl.general —close context

We have gone through the below links and followed all the required stuffs in it, when we check in 2990 it works as expected but somehow the plugin doesn’t seem to work on 8080 port.

Attached the below snapshots

  • atlassian-plugin.xml
    resource type=“download” name=“googlefont.css” location=“css/googlefont.css”
    resource type=“download” name=“spin.js” location=“js/spin.js”
    Project Structure

Hi did you solve this already?

I did manage to include my own CSS and JS but the images are still not getting loaded for me.