Jira Software 9.16 and Jira Service Management 5.16 EAP 02 is now available

Hi, Developer Community! :wave: The second EAP release of Jira Software 9.16 and Jira Service Management 5.16 is ready for testing.

This is a Data Center-only release and it doesn’t support Server licenses. With Atlassian Server end of support, you’ll need to ensure you have a valid Data Center license before upgrading to Jira Software 9.16.0 and Jira Service Management 5.16.

You can download the EAP from this page . If you’re using maven.atlassian.com , ther versions are 9.16.0-m0003 for Jira Software and 5.16.0-m0003 for Jira Service Management.

To find out more about breaking changes, new features, and introduced fixes in Jira Software 9.16 and Jira Service Management 5.16, check out the Jira Data Center changelog

If you have any comments, post them below.

Happy testing,
The Jira Data Center team

Hi @JacekKrawczyk

unfortunately, the dependencies cannot be downloaded from the Atlassian repository :frowning:

atlas-package -U

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  5.739 s
[INFO] Finished at: 2024-05-07T08:13:57+02:00
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project myPlugin: Could not resolve dependencies for project com.itlab.jira.plugins:myPlugin:atlassian-plugin:5.9.0-SNAPSHOT: The following artifacts could not be resolved: com.atlassian.jira:jira-api:jar:9.16.0-m0002 (absent), com.atlassian.jira:jira-core:jar:9.16.0-m0002 (absent): Could not find artifact com.atlassian.jira:jira-api:jar:9.16.0-m0002 in atlassian-packages-external (https://packages.atlassian.com/maven-atlassian-external/) -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException

Cheers
Adam

@adam.labus, you have wrong dependency-version “9.16.0-m0002”. Correct is “9.16.0-m0003”, see Index of maven-external/com/atlassian/jira/jira-api/9.16.0-m0003

Fyi, EAP-versions often differ from maven-dependency versions. Please take extra care here. As is the case here: EAP 02 vs. m0003

1 Like

Hi @AndreasEbert

you’re right and I realize that EAP numbers do not always correspond to the maven version, but just a moment ago it was version m0002 :wink:
I see that all entries now lead to version m0003, so something has changed.

Cheers
Adam

1 Like