Jira Webhook calling .net wcf service

Hi, I have created a jira web hook and a .net wcf service which needs to be called everytime a jira issue is updated/created. Even though it says we need to use a ‘https’ url when i tried with http it did generated logs with error saying ‘Method not allowed’.
Now i have created a secure URL with and tried. It does not seem to work.
Anyone who can help me ?

No logs generated as well. I am new to Jira. Appreciate any help?

@Jeeves123 welcome to the Atlassian developer community.

When I develop with webhooks, I prefer to separate the HTTP problems from my code problems using an HTTP proxy. The classic tools for this are Fiddler or Charles but I’ve come to prefer hosted services like Beeceptor. Instead of configuring Jira to send webhooks to your WCF service directly, you send to the proxy, then tell the proxy to forward to the WCF service. This way you can debug the HTTP level problems more easily. For example, the proxies will accept all methods and show you what Jira is trying to send. To me, that makes it much easier to fix my code to fit what Jira is sending.

Those tools would help us know more about the problem you are having so we can provide better advice. Let us know if you have any errors in the proxy. If not in the proxy, then we might need to see some code to know what’s going wrong.