JQL in JIRA Java Rest API SearchRestClient.searchJql()

I tried to use JIRA Java Rest API to get issues, it does return (first) 50 issues:
SearchRestClient.searchJql(“project = ‘TES’”).claim();

Then I tried to get more:
SearchRestClient.searchJql(“project = ‘TES’ and startAt=51”).claim();
SearchRestClient.searchJql(“project = ‘TES’ and maxResults=200”).claim();
SearchRestClient.searchJql(“project = ‘TES’ and startAt=101 and maxResults=20”).claim();

But I always get the following error (maxResults is the same):
[ErrorCollection{status=400, errors={}, errorMessages=[Field ‘startAt’ does not exist or you do not have permission to view it.]}]

Is there any setting I need to complete? OR my JQL is incorrect?

Please help! Thanks in advanced.

Rather than incorporating the startAt parameter into the JQL, pass it as a separate argument:

Promise<SearchResult> searchJql(
    @Nullable String jql, int maxResults, int startAt)

See SearchRestClient JavaDoc.

Thanks, David, it works!
The question is: with two signatures there, how do I know they are NOT equal? Is there any JIRA Java Rest API Developer’s Guide? The tutorials (https://ecosystem.atlassian.net/wiki/spaces/JRJC/pages/27164680/Tutorial) is for 1.x and is too simple only enough to get started.

I don’t know of any Jira Java Rest API Developer’s Guide. The nice thing about that library, though, is that it’s Open Source. You can see what it’s doing under the covers. You can see there that one method delegates to the other.