Lesson 1 npm start not starting addon

Hi, new to the confluence cloud forums

I’ve been following along on with this tutorial: https://developer.atlassian.com/cloud/confluence/lesson-1-the-source-awakens/ and have come to run the addon, however I don’t get the expected output and I’m not sure why.
image

This is as far as it gets. Any help is much appreciated.

Cheers

Hello @hamish.burns,

The log seems correct and the has been already started. Have you tried going to the URL where the server is running at? If the app successfully started, it should display your descriptor file.

If you can see the descriptor file, next step is to make it available for your Confluence Cloud instance to see. In this Getting Started guide, ngrok is bundled with ACE and will handle the tunneling for you. I believe that is what’s missing in your logs, establishing the tunnel. Can you check if you have ngrok by running ngrok on your terminal?

Thanks,
Ian

Hi iragudo

The URL is showing my descriptor file, so onto the next step.

I ran npm install --save-dev ngrok@2 however this lead to no change after running npm start. How do I run ngrok on my terminal to check if I have it installed properly?

Thanks for your help!

You’re welcome, @hamish.burns.

Running ngrok should be sufficient

For a Windows machine, if ngrok returns something like a bad command or file name, I believe you need to add it in your path first.

Cheers,
Ian

Hi Ian

Have added ngrok to my system path and after creating a new app was able to get tunnelling working for that app. For some reason the previous get started app is still not working, but this is not a big deal.

Thanks for your help

1 Like