Listener not getting triggered


I started seeing stage 1 on app access screen

After this when I try to migrate, it is not going in below method

public class MigrationListener implements CloudMigrationListenerV1 

public void onStartAppMigration(String transferId, MigrationDetailsV1 migrationDetails) {
//code here

I have tried migration multiple times for my testing purpose by enabling dark feature for development

My Questions:

  1. The “onStartAppMigration” was working correctly and it stopped getting called, what may be the reason?

  2. If i run migration again, I can see “migration complete” status and “App data migration in progress”, but in Cloud i only get event with webhookEventType=‘LISTENER_TRIGGERED’ and not getting “APP_DATA_UPLOADED”.

  3. How to update the app migration status for older migrations, if migration still in progress? I tried to call

curl -u admin:admin -X GET "http://localhost:2990/jira/rest/migration/latest/app-migration/rerun/0170e5ed-c98a-4305-b01f-859b49ec2605"

But was not able to rerun the migration! How can i update the status for these old migrations?


Suddenly it started to trigger onStartAppMigration again, I am not sure what caused this, but i have not changed any code or settings

Hi @shiv,

We had an issue with the back end of the App Migration Platform that we resolved yesterday and this is what probably fixed your issue.

Thanks for letting us know. If you have any more issues with your app migration steps please let us know.