Loading resources in Service Desk queues view

I am having a problem with web-resource files not loading in the Service Desk “queues” view, when viewing issues.

I am trouble-shooting a plugin that includes a webpanel to load a button in the “atl.jira.view.issue.right.context” location for issues. The panel loads successfully and displays the button in both the “issue” (e.g. /jira/browse/HD-1) and “queues” (e.g. /jira/projects/HD/queues/custom/1/HD-1) views.

The problem I am seeing is that the plugin’s associated web-resource files (JavaScript) load when viewing the issue directly but not when navigating to the issue via queues. The result is that the plugin does not functions when viewing an issue from a queue.

Is there a way this can be made to load the necessary web-resource files?

1 Like

Please post the relevant web-resource definition from your atlassian-plugin.xml file.

Thanks David.

Here’s the relevant section:

        <web-resource name="Engage Web Resources" key="engage-resources">
                <dependency>com.atlassian.auiplugin:ajs</dependency>
                <resource type="download" name="angular.min.js" location="/lib/angular.min.js" />

                <resource type="download" name="bootstrap.min.css" location="/lib/bootstrap.min.css" />
                <resource type="download" name="ng-tags-input.min.css" location="/lib/ng-tags-input.min.css" />
                <resource type="download" name="ng-tags-input.bootstrap.min.css" location="/lib/ng-tags-input.bootstrap.min.css" />

                <resource type="download" name="ng-tags-input.js" location="/lib/ng-tags-input.js" />
                <resource type="download" name="angular-translate.min.js" location="/lib/angular-translate.min.js" />
                <resource type="download" name="angular-messages.min.js" location="/lib/angular-messages.min.js" />
        </web-resource>

And, at the top of the velocity template, there is:

$webResourceManager.requireResource("com.xmatters.xmatters:engage-resources")

In the head section of the rendered HTML for the issue view, I see a script tag with a src attribute for loading engage-resources.js. The same does not exist in the queues view, however.

I don’t know what’s going on there, but if I had to guess, maybe the $webResourceManager isn’t there when you view the issue via queues. Perhaps you might try explicitly putting an instance of com.atlassian.plugin.webresource.WebResourceManager into the rendering context, if you aren’t already doing that.

I just had a chance to get back to this. I have explicitly added com.atlassian.plugin.webresource.WebResourceManager into the rendering context as suggested, but no change, unfortunately.

Have you tried to include the jira.view.issue context in your web-resource definition? Then it will be automatically included in all view issue pages, which would include accessing the issue through SD queue view.

https://developer.atlassian.com/display/JIRADEV/Web+Resource+Plugin+Module#WebResourcePluginModule-WebResourceContexts

I had tried that context (jira.view.issue), along with the rest of the other related contexts mentioned in the article but none seem to do the trick, unfortunately.

Just wondering, is there a js file named engage-resources.js set to download for the web resource?

I guess it must have an entry point, but might just querying, as seems strange to not be present.

Try sd.project.view it worked for me