Manifest validation failed - Forge Deploy

Hi,

I’m having troubles when I try to deploy my app. I tried to “forge deploy --verbose” and details above:

ℹ Validating manifest
  Upload URL is valid
  Found manifest file
  Manifest is a valid YAML
  Manifest validation failed
Validation errors: {
  "validationResult": {
    "tid": "c3558d2ad1eab835",
    "code": 400,
    "type": "UpsertEnvironmentRequestInvalidError",
    "message": "Upsert Environment Request body is invalid. Details "
  }
}

Error: Deployment failed

Error: Deployment failed
    at ArtifactDeployer.handleErrorEvent (/Users/alimertkoc/.nvm/versions/node/v12.22.6/lib/node_modules/@forge/cli/out/deploy/deployer/deployer.js:151:15)
    at ArtifactDeployer.pollAndCheckEvents (/Users/alimertkoc/.nvm/versions/node/v12.22.6/lib/node_modules/@forge/cli/out/deploy/deployer/deployer.js:61:18)
    at processTicksAndRejections (internal/process/task_queues.js:97:5)
    at async ArtifactDeployer.monitorDeployment (/Users/alimertkoc/.nvm/versions/node/v12.22.6/lib/node_modules/@forge/cli/out/deploy/deployer/deployer.js:72:28)
    at async ArtifactDeployer.deploy (/Users/alimertkoc/.nvm/versions/node/v12.22.6/lib/node_modules/@forge/cli/out/deploy/deployer/deployer.js:36:9)
    at async PackageUploadDeployCommand.execute (/Users/alimertkoc/.nvm/versions/node/v12.22.6/lib/node_modules/@forge/cli/out/deploy/package-upload-deploy.js:14:9)
    at async CommandLineUI.displayProgress (/Users/alimertkoc/.nvm/versions/node/v12.22.6/lib/node_modules/@forge/cli/node_modules/@forge/cli-shared/out/ui/command-line-ui.js:44:28)
    at async DeployView.reportDeploymentProgress (/Users/alimertkoc/.nvm/versions/node/v12.22.6/lib/node_modules/@forge/cli/out/command-line/view/deploy-view.js:50:24)
    at async DeployController.run (/Users/alimertkoc/.nvm/versions/node/v12.22.6/lib/node_modules/@forge/cli/out/command-line/controller/deploy-controller.js:122:27)
    at async Command.actionProcessor (/Users/alimertkoc/.nvm/versions/node/v12.22.6/lib/node_modules/@forge/cli/out/command-line/command.js:76:32)

I searched it online but can’t find any useful thing to solve my problem. Can anyone detect the what problem is and have any solution?

Thanks already,
Ali Mert

Do you happen to have any overlapping key/function names?

I just hit the same thing when I had this in my manifest.yml:

webtrigger:
  - key: webtrigger
    function: webtrigger
function:
  - key: webtrigger
    handler: webtrigger.run

But the deploy error goes away if I switch it to:

webtrigger:
  - key: webtrigger
    function: web-trigger-function
function:
  - key: web-trigger-function
    handler: webtrigger.run
1 Like

I ran into the problem as well. But I cannot find the reason, because I didn’t change any code. So I invalid the cashes and restart IDE, it goes well.

1 Like

I ran into this issue today. I haven’t done any code change since last deployment. I have just upgraded @forge/cli. For my case it was two extra attributes in “jira:adminPage” module, description and label. This was working until now for a long time. forge-lint doesn’t complain about them. I think there is a room for improvement here;

  • forge lint command should catch extra attributes
  • Error message should be fixed. Seriously, what does "Upsert Environment Request body is invalid. Details " means. There is no details other than a stack trace.

This post could be the answer: Forge Deployment Fails with Error

1 Like