Minification of JavaScript files - Jira Plugin Development

Started develop environment with parameter : -Datlassian.webresource.disable.minification=true and using atlas-debug to start development environment. JavaScript files are now minified.

How can minification be disabled again?

SDK: 6.2.14

Apache Maven 3.2.1 (ea8b2b07643dbb1b84b6d16e1f08391b666bc1e9; 2014-02-14T18:37:52+01:00)
Maven home: atlassian-plugin-sdk-6.2.14/apache-maven-3.2.1
Java version: 1.8.0_121, vendor: Oracle Corporation
Default locale: de_DE, platform encoding: UTF-8
OS name: “linux”, version: “4.4.49-16-default”, arch: “amd64”, family: “unix”

Hi,

I usually use compressResources option set to false in pom.xml to disable minimization which by default is enabled and don’t use any startup flags.

Vasiliy

Hi,

I tried that, but it is not working.

My Atlas-Version is 6.2.14, AMPS Version 6.2.11.

Can you copy/paste the relevant sections of your pom.xml here?

Hi,

I tried:

                       ```
  
				com.atlassian.maven.plugins
				maven-jira-plugin
				${amps.version}
				true
				
					false
					true
					false

........

In addition, i tried: 


				net.sf.alchim
				yuicompressor-maven-plugin
				
				0.7.1
				
					true
				
			
debug environment started up with:
atlas-debug " -Datlassian.dev.mode=true -Datlassian.webresource.disable.minification=true`Preformatted text`

Looks like that second attempt should work as documented here https://developer.atlassian.com/docs/advanced-topics/supporting-minification-of-javascript-and-css-resources#SupportingMinificationofJavaScriptandCSSResources-DisablingMinification

I’ve opened up an issue to investigate. https://ecosystem.atlassian.net/browse/AMPSDEV-215

There are serious issues with the SDK.

Problem occurs, when trying to run against Jira-Version 7.4.x.
fastdev does not work
atlas-cli does not wrork
using QuickReload (disabling fastdev) works for reloading the plugin, BUT

  • if you press then “b” in the quickReload servlet, you get the code not minified, BUT you get tons of JS errors from Jira. As a result, your own JS-Code (attached on AJS events) ist not executed any longer.
    So it is NOT possible at the moment to develop against Jira 7.4.3.

Building a complete new plugin project, using the default setup for the pom from the sample plugin produced these errors.

So this is a serious issue for ALL plugin developers having JS code in their pages!

@jiraplugins, @rwhitbeck

This seems to still be the case. I have upgraded my SDK from 6.2.15 to 6.3.6 and now I have the same issue. QuickReload seems to be by default and loads JIRA in production mode. Going to the servlet and pressing “b” toggles dev mode to “on” and batch mode to “off”. However, every reload after that, Jira is broken. You cannot even open the Edit dialog mode and the customfield inline edit is also broken.

That is indeed a serious problem, how are we supposed to debug our add-on now?

Also, the AMPSDEV-215 doesn’t lead anywhere. I assume that it’s an internal project. Any link to a public issue?

Hi,

try the pom (only fragment) below and start with:

atlas-debug --jvmargs “-Datlassian.webresource.disable.minification=true”

Use chrome to find javascript source code using

image
… Go to file…

Using this we are still able to use atlas-cli (pi) to redeploy. Do not touch the quick reload page.

<build>
    <plugins>
        <plugin>
            <groupId>com.atlassian.maven.plugins</groupId>
            <artifactId>maven-jira-plugin</artifactId>
            <version>${amps.version}</version>
            <extensions>true</extensions>
            <configuration>
            	<!--  define the product... -->
                <productVersion>${jira.version}</productVersion>
                <productDataVersion>${jira.version}</productDataVersion>
                
                <enableQuickReload>false</enableQuickReload>
            	<enableFastdev>true</enableFastdev>



put your jira target version here
<jira.version>7.3.8</jira.version>
<amps.version>6.3.4</amps.version>

br,

1 Like

Thanks @jiraplugins!

I guess I had two errors.

  1. I did not specifiy to enableFastDev. I was under the impression that it was removed all together with the new version of the SDK.

  2. I thought that the Datlassian flags were directly passed to the altas scripts. I didn’t think it had to be passed to the JVM.

Still, not being able to debug under QuickReload is a problem especially in light of the fact that they plan to remove FastDev. I vote to keep it in until this is all fixed.