Minification with Yuicompressor

Hello! I tried run my plugin with *-min.js files.

I used this tutorial for this:

I run Jira with atlas-run and expect to see min.js files in browser, but jira loads source files =(

Yuicompressor work good, and i see compressed files in target.

I tried disable quickReload, but it doesn’t help.

I don’t understand this <param name="source" value="webContextStatic"> exprassion. Please, give me link with explain. But iIn this case jira loads my source files with empty content…

jira version 7.0.0
amp 8.0.0
sdk 8.0.7

1 Like

Did you make sure you were on “batch” mode instead of “dev” mode?
You can check and toggle this easily by going to Jira dashboard and pressing “b” shortcut.

.min files should be loaded in batch mode, .dev mode loads source files for easier development

Hello! Thanks you for answer. I tried switch on “batch mode” and in this case i still see source files with full path in file name :anguished:

Does your plugin build contain

        <!----- or maven-jira-plugin-->

by any chance does it have <compressResources>false</compressResources> in configuration?