My Cloud Macro: Error message "App is not responding"

I’m testing my own macro für Confluence (Cloud)

Starting with:

  • Node v12.13.1
  • NPM 6.12.1

https://developer.atlassian.com/cloud/confluence/getting-started/

After

npm start

the last two lines are:

POST /installed 204 46.470 ms - -
Registered with host at https://(MyServerName).atlassian.net/wiki

On the confluence page in edit mode, my " Hello World macro " appears unter Insert Macro -> all.

But if I select the macro, I get the error " App is not responding" in the macro window
Anmerkung%202019-12-16%20133420

" npm start " ist furthermore running an shows no error or information

Any idea, what is missing?

Frank

Hi @FrankLeverenz,

We ran into this issue just last week. I just now went through the tutorial again thinking maybe something needed to be updated.

I’m thinking that you may have a previous instance of the app installed in your Confluence instance and didn’t shut the app down in the correct way so that it uninstalls/deregisters in the site specified in the credentials.json file.

Let’s clean up the apps installed and try again. Can you follow these steps?

  1. Go to Manage apps page as you did in the Getting Started tutorial.
  2. Look for any apps named Hello World click on them to expand
  3. Click on Uninstall to remove the app.
  4. Run npm start in your terminal again and leave the window open
  5. When you’re done running the app do a Control-C this will stop the node app and will uninstall the app before the app completely shuts down.

Let me know if that works for you. We’ll update the tutorial to add in the bit about Control-C so that apps are being shut down correctly.

Ralph

Hi guys,

I was facing the same difficulties as a Frank, so I’ve tried Ralph’s guide. Uninstalled the app and installed it again. I’m able to add macro using button Insert Macro -> all, but cannot search for macro using just typing /
Another question, do I have to leave the terminal still open? I would appreciate, if installed apps would stay in Manage apps section, is it somehow possible?

thanks,
Ludek

Hi Ludek,

my solution:
The problem was, that the cloud macros are using https://ngrok.io/ as a reverse proxy:

Local tunnel established at https://b4f0188a**.ngrok.io**/
Check http://127.0.0.1:4040 for tunnel status
Registering add-on...
GET /atlassian-connect.json 200 12.760 ms - 633

and our firewall (watchguard) was blocking this site.

After setting https://ngrok.io/ to the firewall whitelist, the macro is running

Frank

1 Like

Hi Ralph,
reinstall did not work
see solution: put reverse proxy https://ngrok.io/ to firewall whitelist
Frank