NgrokError when using Forge Tunnel

I spontaneously began receiving the following error. Is this caused by something on the Atlassian side or my environment?

Error: Failed to start tunnel, could not establish a connection.

With verbose, there seems to be related to the ngrok authtoken?

t=2023-12-19T19:08:28+0000 lvl=dbug msg="encode request" obj=tunnels.session obj=csess id=0a1d5c00f336 sid=3 req="&{Version:[3 2] ClientID: Extra:{OS:linux Arch:amd64 Authtoken:
HIDDEN Version:3.5.0 Hostname: UserAgent:ngrok-agent-go/3.5.0 ({\"proxy_type\":\"none\",\"config_version\":\"2\"}) ngrok-go/1.7.0 Metadata: Cookie: HeartbeatInterval:10000000000
 HeartbeatTolerance:15000000000 Fingerprint:<nil> UpdateUnsupportedError:0xc000804500 StopUnsupportedError:0xc000804500 RestartUnsupportedError:0xc000804500 ProxyType: MutualTLS:false ServiceRun:false ConfigVersion: CustomInterface:false CustomCAs:false ClientType:ngrok-agent-go}}" err=nil
t=2023-12-19T19:08:28+0000 lvl=warn msg="failed to check for update" obj=updater err="Post \"\": tls: failed to verify certificate: x509: certificate signed by unknown authority"
t=2023-12-19T19:08:28+0000 lvl=dbug msg="decoded response" obj=tunnels.session obj=csess id=0a1d5c00f336 sid=3 resp="&{Version: ClientID: Error:Usage of ngrok requires a verifie
d account and authtoken.\n\nSign up for an account:\nInstall your authtoken:\r\n\r\nERR_NGROK_4018\r\n Extra:{Version: Region: Cookie: AccountName: SessionDuration:0 PlanName: Banner: DeprecationWarning:<nil>}}" err=nil

i’m having the same error, i thought it was a network problems so i tried with other networks but its the same. …

1 Like

I’ve opened a support ticket, but have not yet received a response. I will update here if there is any new information.

same problem

@AtlassianSupport @Atlassian-Staff

Support ticket for Atlassian Staff reference, ECOHELP-32172



Did you raise the case as an incident? Or as a bug? If as incident, I think you can “share it” and post the issue key here for others to watch, join, and track. In general, this community forum isn’t a good way to get incident updates. It’s not part of our operations processes but both ECOHELP and the developer Statuspage are for these kinds of outages (if they last long enough).

Thanks @DavidPezet1, were you reading as I typed? :wink:

That was raised as a bug and not shared so others won’t be able to follow. I’ll go “poke” the support team and see if we can get some urgency on this. Sorry for the inconvenience.

1 Like

Thanks @ibuchanan!

Sorry, I probably shouldn’t have posted the support ticket as a link. I only meant it to serve as a reference to Atlassian Staff who might be able to see it.

General Atlassian support pointed me to submitting it as a bug. :man_shrugging: If necessary I can submit another as an Incident, but not sure if it’s just static at that point? Or maybe they can migrate it to an incident to share?

At this point, support has picked this up and raised an incident. No need to take further action. Support should keep you in the loop and start updating Statuspage when more is known. I think the yellow banner for “minor incident” is for this incident already, so others can tune in there for more info.

1 Like

Please follow this to set up your ngrok config, the original workaround has been deprecated.


Works for me :tada:

I replied yesterday with some advice to a newcomer that “if there’s an error, my first assumption is it’s on Atlassian’s end because it more often is”. Today alone I reported a breaking REST API change and wasted time on this tunnel issue.

Forge team should use this as suggested years ago: Quick Tunnels · Cloudflare Zero Trust docs

It is clearly worsening the developer experience to now require an ngrok account and configuration file.

It would be really good if we could use Forge without a tunnel. For example by specifying a http endpoint like under our control.
Then we don’t have the issues with ngrok tunneling through our network and basically exposing dev machines to the internet.

1 Like

FYI: Atlassian also announced this change in

1 Like

A post was split to a new topic: How to diagnose “Fatal error in , line 0”?

Edit: The docs mean what they say. I was wrong about the ngrok aspect see my subsequent correction

@marc and others frustrated with ngrok,

A fundamental workaround is to switch to the native Node.js runtime because, as the docs explain:

The new native Node.js runtime no longer requires a local Docker image for invoking your Forge functions locally. This simplifies the local toolchain for setting up the tunnel, and will improve the performance of your tunnel.

In other words, we are moving away from ngrok. When the runtime leaves preview and becomes GA, there won’t be any need for Docker & ngrok to run the Forge tunnel. But, during preview, please be aware the new runtime does have some differences and known limitations.

1 Like

Hi @ibuchanan,

Just to confirm- we won’t need an ngrok account once the runtime becomes GA?

I am currently using the native runtime and needed to sign up for an ngrok account to get my tunnel back up and running.

1 Like

Thanks for prompting @Tristan,

No. I misunderstood the docs.

Pardon my misunderstanding. Somehow I conflated use of Docker with ngrok. I have since been corrected by the Forge CLI team that ngrok is still (and will be) required with Forge native Node.js.

1 Like