No compatible hosts detected

Failed to register with host (200)

    "type": "INSTALL",
    "pingAfter": 300,
    "status": {
        "done": true,
        "statusCode": 200,
        "contentType": "application/vnd.atl.plugins.task.install.err+json",
        "subCode": "upm.pluginInstall.error.descriptor.not.from.marketplace",
        "source": "",
        "name": ""
    "links": {
        "self": "/rest/plugins/1.0/pending/3e4349f2-7c4e-48ff-96cc-7012f6a4b849",
        "alternate": "/rest/plugins/1.0/tasks/3e4349f2-7c4e-48ff-96cc-7012f6a4b849"
    "timestamp": 1621857830605,
    "accountId": "60ab564d6006b00070fc1988",
    "id": "3e4349f2-7c4e-48ff-96cc-7012f6a4b849"

Add-on not registered; no compatible hosts detected


:wave: Looks like you’re running into an error. Do you have a specific question you’re looking to get answered?

I’d recommend checking out the How To Ask A Good Question ❓ guide for some tips on improving your post to increase the likelihood that someone is able to help you out.

I have the same issue today. Seems like yesterday my addon worked fine, but when I tried to start it today I got the error from the first post message. Even when I follow the atlassian-connect-express guide Bitbucket and create brand new addon and new cloud atlassian site I get the same error when trying npm start (credentials connected with API token ). I can’t understand what I am doing wrong. I can not even upload addon manually, it also returns an error

1 Like

I have this exact problem today. Very frustrating! :frowning:. It can upload the connect app fine when authentication.type = 'none' and there are no lifecycles. If it’s authentication.type = 'jwt' with lifecycles it errors with the mentioned error.

1 Like

Yes, I somehow noticed this dependency with authentication as well. And also I noticed that downgrading module atlassian-connect-express (in package.json) to “~6.6.0” also helps with this error, hope that might be helpful. Wondering what is wrong with this stuff…

1 Like

I’m having the same issue and none of the solutions mentioned above are working for me. That is stopping me from continuing with the development of the app!

I’m using the latest version of Atlassian Connect Express (ACE), React for the frontend of the application and MongDB for storing.

Would be pretty thankful if anybody could help me with this.


Hi, here is a workaround for this issue:

If you see this error after running npm start, you can go to your testing site → Apps → Manage apps → “Upload app” (it will appear if Enable development mode is checked in “Settings”), and then fill in the descriptor URL, e.g,
It could take about 1 minute or so to finish.

You can also see at the same time from your console that your app is successfully registered and installed:

GET /atlassian-connect.json 200 5.530 ms - 710
Saved tenant details for ... to database
  key: 'webhooks-app',
  clientKey: ...
  publicKey: ...
  serverVersion: '6452',
  pluginsVersion: '1.1106.0',
  baseUrl: 'https://.../wiki',
  productType: 'confluence',
  description: 'Atlassian Confluence at null',
  eventType: 'installed'
POST /installed 204 54.444 ms - -
GET /atlassian-connect.json 200 0.872 ms - 710

I hope this helps.


1 Like

I have the same issue. If I copy the descriptor url and paste it in the browser address bar, the descriptor file is served up no problem. So, my app services is running and ngrok is working. If I try to upload the addon on the ‘Manage Apps’ page in Jira, it says that it cannot access the file. Jira is having trouble with Ngrok, or my ISP or some other network issue.

Sometimes, eventually, it works but not always.