Not able to deploy the FORGE custom UI app, reason: Socket connection timeout

When i run “forge deploy --verbose” ending with below issue

Error: request to failed, reason: Socket connection timeout

FetchError: request to failed, reason: Socket connection timeout
at ClientRequest. (/usr/local/lib/node_modules/@forge/cli/node_modules/node-fetch/lib/index.js:1491:11)
at ClientRequest.emit (node:events:523:35)
at ClientRequest.emit (node:domain:489:12)
at TLSSocket.socketErrorListener (node:_http_client:495:9)
at TLSSocket.emit (node:events:511:28)
at TLSSocket.emit (node:domain:489:12)
at emitErrorNT (node:internal/streams/destroy:151:8)
at emitErrorCloseNT (node:internal/streams/destroy:116:3)
at process.processTicksAndRejections (node:internal/process/task_queues:82:21)

I have logged in with email and API-TOKEN, tried setting up the variables
tried by changing the n/w and tried with sudo permissions.

Can anyone help me with resolving the issue.

More details :
npm version : 9.6.4
forge version : 6.9.0
node version : v20.0.0

Hey @MillenialRetail,

I’d start by seeing if you can access the url that is timing out via your terminal - say by running a

curl -v

if you’re unable to access it, you may need to check that your computer or network aren’t blocking your access.


Hello @mpaisley ,

Thank for your response.
I am able to connect from the terminal when i run that command, look at the below screen shot.

A socket timeout means that there is a connectivity issue somewhere between your machine, and the amazonaws resource.

Looking at my own forge app deploying, I’m using the same URL as part of the upload process, without seeing any errors, and I’m not aware of any other users reporting a similar issue - so I strongly believe the problem is not related to the amazon resource.

It is possible that the error is being caused be a slow internet connection (possibly related to your upload speed), or it could be that a firewall or proxy is blocking certain ports. You could review your firewall settings for exceptions, or try a different network or computer system. You may need to speak to your system or network administrator for further assistance.

I hope this helps point you in the right direction.


Hello, I have the same issue. Were you able to fix it?

Cheers, Michael