Not able to install Forge-CLI

Hello,

I am trying to install the new forge platform following this tutorial: https://developer.atlassian.com/platform/forge/set-up-forge/

After installing the right version of node and python, when I run “npm i -g @forge/cli” I come into this error:

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! @forge/util@0.2.4 postinstall: `./scripts/postinstall.sh`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the @forge/util@0.2.4 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

I tried to install different versions and the result was the same.

Any ideas?

Kind Regards,
Philip

Hi Philip,
It is not entirely clear from this snippint what went wrong. Would you mind sharing full log produced by npm i -g @forge/cli command. We would like to investigate the issue and having full log will greatly help us.

1 Like

Let’s follow this up on https://ecosystem.atlassian.net/browse/FRG-32

1 Like

Hi Philip
I’m having the same issue.
Have you come up with any solution?

There is new version of Forge CLI (0.6.2) that fixed this problem.
Just install it again.

npm install -g @forge/cli@latest