Not able to publish our cloud app in marketplace

Hi Team,

We created our cloud app and we deployed in azure with HTTPS domain. If we try to install app descriptor file through publish app option then it is throwing error.

Error:
“The Marketplace can’t download your add-on using the provided URL. Provide a publicly accessible URL for your add-on”

App Descriptor URL:
https://xxxxxxxxxx.com/atlassian-connect.json

but this is a public URL can access anywhere why marketplace not able to download my app descriptor file?

@rwhitbeck is it released something ssl certificate?
@danielwester

I’m sorry @dchouksey89 there isn’t enough information here to determine what could be the problem.

This seems like it would be better handled by the DEVHELP service desk so that we can help debug with the more private information we would need to be able to help debug the problem.

Can you open an issue at http://go.atlassian.com/devhelp?

Thanks!

1 Like

I would go the DEVHELP approach, but you might also just want to verify that you can fetch the url from command line using curl or wget. (ie outside of the browser). From my past experience - the Atlassian Marketplace can be finicky about ssl certs. Also, check the “self” url property in the descriptor.

2 Likes

Hi @danielwester & @rwhitbeck,

I missed a few extra certificates to add in App,js file. Now it is working fine. I have successfully published the app and I am able to install also in my dev instance.

Added Code in App.js

import https from "https";
import fs from "fs";

var options = {
    pfx: fs.readFileSync("./cer/xxxxxSSL06212xxxxx.pfx"),
    passphrase: 'xxxxxxx',
  ca: [
          fs.readFileSync('./cer/CACertificate-ROOT-2.crt'),
          fs.readFileSync('./cer/My_CA_Bundle.ca-bundle')
       ]
};

// Boot the HTTPs server
https.createServer(options, app).listen(port, () => {
  console.log("App server running at http://" + os.hostname() + ":" + port);
  
});

Hi @dchouksey89,

Happy was able to help find problems in cert. Glad you’re able to publish now. Thanks for raising in devhelp!

Cheers,
Anne

1 Like

Great, thanks for the follow up! Please make sure to follow up on your DEVHELP ticket as well letting them know that you got things working.

1 Like