Numerous problems with atlas-run


I’ve been trying to get a local confluence server running using atlas-run from the latest SDK (6.3.6) for a while now. However, most of the time the script stops in the middle of the procedure. Mostly at the line

[INFO] com.atlassian.synchrony:synchrony-proxy:2.0.1:war already exists in H:\Development\W3L.Confluencer\target\confluence\synchrony-proxy

Sometimes it continues after a longer while (10-15 minutes), most of the time it doesn’t. When I finally reach the lines

[INFO] [talledLocalContainer] INFORMATION: Server startup in 15490 ms
[INFO] [talledLocalContainer] Tomcat 8.x started on port [1990]
[INFO] confluence started successfully in 623s at http://WKS25:1990/confluence
[INFO] Type Ctrl-D to shutdown gracefully
[INFO] Type Ctrl-C to exit

I just get an error when I try to access http://wks25:1990/confluence:

type Status report

message /confluence/

description The requested resource is not available.

Do you have any ideas what’s going on or where I might find more information? I also tried running atlas-run --debug but I didn’t get more useful information from that.

I just found out that the directory “.\target\container\tomcat8x\cargo-confluence-home\webapps\confluence” contains no .html files or similar stuff. There’s just a WEB-INF folder?

Have you tried doing an atlas-clean on your confluence plugin directory before an atlas-run?
Particularly if the process wasn’t shut down using Ctrl-D it can cause some issues with the container and so cleaning and recreating it is your best bet.
I’ve just verified on a windows 10 machine, and I was able to start confluence and access it both at:

  • localhost:1990/confluence; and
  • machine-name:1990/confluence
    Let me know how you go.