OAuth for 3rd party application like Outlook not working

I have a forge app named JAssistant which integrated with Outlook Calendar for pulling events. This has been working fine since long time. But since past few weeks this has stopped working.

It behaves differently in each environment. I am using forge bridge library and all the libraries are up to date. I am not using any out dated libraries.

First for PROD environment I am getting following error: “container or service was not found in the store” displayed on screen. I tried re deploying the code and still the issue is not resolved.
Some of the users have complained that they are going on a circular loop instead which I was not able to reproduce. I am sure this is not an issue with the application code as it is available as Web and Browser extension as well where it is working fine. Also this code was unchanged since months and it used to be working fine earlier.

In Staging environment: In lower environment it behaves differently. It allows me to give consent in MS Outlook OAuth site and when it comes back, it says invalid client secret provided. I have been using the same secret since long time and it was working fine. I have already verified that the secret is still not expired. Any way, I have tried generating new secret as well and updated it and still the same issue. I am pretty sure that I am not doing any mistakes while updating the secret. With same secret I was able to get the same application working as Browser Extension. So I strongly believe it is something to do with Atlas end.

Anyone who had already authenticated / given consent with Outlook do not have any issue. They were able to use the application without any issues.

Please let me know if you need any further information to help you in debugging the issue. I believe you would be able to fetch the application details using my mail id and so not providing it here. If at all any additional information is required, please let me know.

Hi, Are there any updates on this yet?

Hi @Shridhar, thanks for your patience. It seems like that second error is coming from a mismatched client ID and secret coming from Microsoft. We would recommend checking that your client secret matches the client ID.

For the first issue, we need some more context about the error (e.g. what screen it showed up in, URL, browser information, etc.) and a trace ID for the request that returned this error. To do so, could you raise a private support ticket so that we can exchange this information? I believe you can do so here: Atlassian Support.


1 Like

Thank you for your reply.

However, As I already mentioned, With same client id and credentials it was working fine since long time and all of a sudden it stopped working in Cloud App alone and with same source code and credentials it is still working in browser extension instance of the app.

And for the second issue, I don’t see any option to raise a ticket in the link you provided. If I select category as Jira Software, it ask me to use the community for support. If I select marketplace app also it doesn’t have an option to raise private ticket. Is there any other way I can provide the Url instead?